WifI won't login


I paid $300 for this thing. You better believe I want this working.

Is there a way to do a factory reset? That might solve it.


Just to reiterate,

  • from the terminal, an ‘ifconfig wlan0’ shows the Pi has a valid IP address
  • If you try and use the browser, you can’t get to the internet (or do updates from Piper)
  • you can ping other devices on your local network and they can ping the Pi
  • in terminal a ‘ping’ gets a ‘Network is unreachable’ message

If all that is true, I think it has something to do with your router. Since the Pi gets an IP address, it is talking to the router. Since you can ping your laptop from the pi and the pi from your laptop, the local network is fine. Since your laptop can get to the internet and teh Pi can’t this tells me that the router is the issue.

Did you buy the router yourself or was it installed by your provider? If it was installed by your provider I’d suggest you contact them to see if they can explain how a device that connects to the router getts an IP address but can’t get to the internet. I’ve never seen this router and have no experience and can’t find anything on the internet about how to trouble shoot it.

I’ll ask one of the Piper guys to pipe in on this thread too.


All that is correct. BTW, I’m in Sweden. I don’t think it would make a difference but it might be good for you to know.

So you’re saying that if I tired another network, it would work. I’m using my phone as a wifi hotspot. I’m still getting the same results.I really don’t believe it’s the router since I have several devices using the router. The problem is either a software or a hardware issue. I’m inclined to believe it is a software issue. If I could wipe it, reload the software, and if the problem still exists, I would consider it a router issue.


Well you could always reflash the SD card. see this thread.


Problem solved. I got a new 16GB SD card and added the latest version of the software to it. Once I rebooted, it took the wifi password and updated the software immediately. Thanks for all your help Paul.


Glad you got it working!!!


I had all the exact same issues, faithfully reproduced all the problems described above, went through each prescribed fix and finally had to reflash the card. We’re a school with 10 Pipers, and just one of ours was doing this, so near the end I tried just using a different Piper’s SD card and got onto the wifi with no issue, which made me pretty sure reflashing would work.

Very weird that something can get so messed up that nothing above fixes it.