WifI won't login


#41

Ok, that is showing you have a valid IP address and shoud be connected to your network.

Try doing a ‘ping -c 3 8.8.8.8’ in terminal or opening the browset and going to google/com - do you get to google or does the ping return values?


#42

When I do a ping, I get a ‘Network is unreachable’ message.


#43

Then you probably have a router issue. Do you have another computer connected to the router that can get to google?


#44

Well I am using the same wifi connection on the Piper that I’m using for the laptop I’m writing this response on.


#45

from your laptop, can you ping the pi 'ping -c 3 192.168.1.12’
If your on a mac, just go into terminal, if your on a PC…I have no idea how you would do it…

also find tthe laptops IP and see if you can ping it from the pi


#46

I don’t have admin privileges. Access denied. If I just do a ping without the ‘-c 3’, I get a ‘Destination host unreachable’ message.


#47

If you plugin a cat5 cable into the pi and type ‘ifconfig’, what IP address does it show for eth0


#48

inet addr:192.168.1.13 Bcast:192.168.1.255


#49

And can you ping your laptop or pine 8.8.8.8 (which is google)


#50

I can ping my laptop from the Piper box and I can ping the piper box from the laptop. But I can’t ping outside addresses on the Piper box.


#51

My guess is this has something to do with your router. The pi is talkiing to the router, otherwise it wouldn’t get an IP address. But Something in the router is not allowing it to talk to the outside world.

What make and model is your router, I’m at a loss at the moment. Oh and sorry for the delays, we have a snow storm here and I need to go out and shovel.


#52

No worries. I have an Inferno FG500P, GPON FTTH gateway.


#53

I followed the steps in this video https://www.youtube.com/watch?v=LL4TtWegvnI&feature=youtu.be and wiped the network info, saved and rebooted. The Piper software loads and I can enter the password, nothing happens.

I go back to the desktop and right click on the network icon, select WiFi Networks (dhcpcdui) settings, select SSID and instead of showing me a list of available networks, the old network that I originally tried to connect to in the US appears.

Could the software still be trying to connect to an old network and needs some kind of deeper software wipe to clear out the memory?

Since I entered the password in Piper, when I check the wpa_supplicant.conf file again, the network and password are there. I delete them, reboot and go back to desktop. Now, I can select my network from list of available networks. However, the icon on the available networks appears as paper with a yellow dot in the top left corner. The original network I tried to connect to is still among the listed networks but the icon is like a download to your harddrive icon, box with a green arrow.


#54

I just tried what you say is happening.

  1. I editied wpa_supplicant.conf and cleaned out all the network info.
  2. I turn on an extra wifi router I have and it shows on the dashboard WiFi tool and I select it.
  3. enter the password and connect
  4. If I look at wpa_supplicant.conf now, that network’s info is in there.
  5. I unplug that router and go to the desktop and connect to my home network (different ssid)
  6. look at wpa_supplicant.conf and both networks are there.
  7. clean out wpa_supplicant.conf and reboot
  8. go to the desktop wifi icon and now only my home SSID shows up.
    Are you sure when you fires tried to remove the old wifi network in wpa_supplicant.conf, you saved the file?

could you, in terminal, enter
cat /etc/os-release

and report the VERSION_ID= line. I might be on a newer Raspian version than you.


#55

I rebooted and double checked the supplicant.conf file. It is still missing the network information.

I’m running version 8, Jessie.


#56

so the wpa_supplicant.conf has no network info, but when you click the network icon on the desktop, you see both your current SSID and the old one. Is that correct?


#57

Yes, I see all available networks, plus the old one.


#58

can you try this
cd /etc/NetworkManager
and see if it comes back with ‘No such file or directory’


#59

That’s what I get. No such file or directory


#60

Ok, that’s what I hoped for. I’m at a loss as to why the old SSID should be showing up. I can’t find anything on the internet to explain this and I can’t reproduce it. The only way forward would be for you to make a copy of the sd card and send it to me so I could examine what is on it (of course it will be like taking a kid in pain to the doctors. As soon as you get there, they don’t hurt anymore.

Are you interested in continuing, If so we can take this off line.