WiFi won't connect on Raspberry PI 3


In the Piper Mine craft interface, the button on the robots chest doesn’t appear to do anything. When I click on the green bolt and click on the green wifi configure button, it dumps me back to the main screen. I’ve exited out of the game and tried going into the desktop. I click on the network connections, click on my network, add the password and get the following error message ‘invalid argument’.

I’m using the Raspberry Pi 3 model B V1.2.


Hi, so if you haven’t tried this fix for wifi issues, could you follow these instructions and post the result please.


For WiFi issues please follow the steps in this thread: WiFi connection problems? try this


Ok. Getting closer. I’m connected to my wifi. But now I get the message ‘Network login required. Exit and open a browser window?’. I click confirm and a browser window opens with thE message “Ooops! It was not possible to show this website” http://www.playpiper.com Could not connect: Network is unreachable.

I can reach other websites. I can get to the website on my phone. Just not through the piper. Also, the eth0:link is down is there. Should that change?


@Blabbermoo - please only post in one thread. multi posting just means more work for people trying to help and it might get you ignored…


Yeah. Sorry about that. I’ll just post in the other thread.


Which of the two fixes got you to where you are now?


I followed the video and I got the desktop to connect but I couldn’t get the Piper software to connect to the wifi. I’ve replied in this thread. WifI won’t login


I’ve kind of given up at the moment on the wifi. I connected an ethernet cable to the Raspberry Pi card and tried to download the update through that. The update button is green but I get the message, “Oops! Having trouble connecting to our update servers.”

Any suggestions on how to fix that?