WiFi connection problems? try this


If you are having a problem getting WiFi to connect please try the following:

  1. open a terminal window and type (make sure it is exact):

sudo iwlist wlan0 scan | awk ‘/ESSID/’

this should return a line like this:

ESSID:“Mines of Moria”

so the SSID is “Mines of Moria” (yours will be different) NOTE: if you have a hidden network, go to step (2)

  1. you have to edit a configuration file so type

sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

it should have the following in it:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

at the bottom type the following:


using your SSID (from step 1) and your WiFi password.

  1. Press CTRL+X to exit and you will see the line:

Save modified buffer (ANSWERING “No” WILL DESTROY CHANGES) ?

Press ‘Y’ save, pressing Y and you will see the line:

File Name to Write: /etc/wpa_supplicant/wpa_supplicant.conf

Press Enter to confirm.

  1. Reboot the system by typing:

sudo reboot

  1. when the Pi finishes booting see if the WiFi icon is now green

WiFi won't connect on Raspberry PI 3
WifI won't login
Unable to configure wifi
How do you turn on Wifi?
WifI won't login
Boot to desktop then slow load
WifI won't login

I get to the end of step 3, but “control x” doesn’t do anything


You press and hold CRTL the press the ‘x’ key. Down the bottom of the window it should show this command.


Thx, Paul. Still no luck.

I should note that after ste 2, the ntwk ssid and password are presented to me already entered (i.e. I don’t have to/can’t enter).

At that stage, pressing and holding control x does nothing (no command visible at bottom of screen).


@tomfinn, your problem might be that the Terminal windows extends below the visible part of the screen. Try double-clicking the title bar of the Terminal window itself which will resize it to fit the screen.


thx, that did allow me to
see bottom of screen; but when I hit Control X it only takes me back to terminal screen without the “No Yes” option.

sorry to be such a bother.

Tom Finn


My bad…If you don’t make a change to the file, there is nothing to save so you who’t get the save dialogue.

Can you type in ‘ifconfig’ and see if the WLAN0 section shows an IP address.

(sorry to take so long to reply - I had to drive into the big city to rescue my son and his family who were coming up from Floridia last night at the end of the snow storm and gould not get out of the city (think hotel room with 4yr old bouncing on the bed at 1:30 AM)


@tomfinn I can see that @Paul was faster than me to reply explaining why you did not get the save dialogue. :slight_smile:

Apart from @Paul’s advice wrt “ifconfig” I would like to add, that I would advice you to change your WiFi password. It might sound a little paranoid but you have posted a screenshot above showing your SSID, the WiFi password as well as having your phone number in the message footer. That could tempt someone to try to get access to your WiFi, so please change the password on the router / access point – and then of course also remember to change it in the wpa_supplicant.conf file or you will still have problems connecting to the WIFi.

Best regards,
Martin (another Piper user)


thx, Martin!

Tom Finn
+1 410 812 3160


Martin, per your counsel, I would like to delete my post but am unable. Perhaps because I am a new communicty member, I have limite utility. Any advice?



@tomfinn It looks like someone deleted your original post – the one with the screenshot. If it was not yourself, here is an explanation about how to delete your own posts.

Click the “…” button below the post you want to delete. More buttons appear including one depicting a trash can. Click that to delete the post.

However, even though your post is now deleted, I would still recommend that you change your WiFi password as web pages are kept in caches (e.g., Google and Web Archive).


@tomfinn - once you have a new password in the wpa_supplicant, please issue the ‘ifconfig’ to see if you get an IP address.


I’m trying to connect to our School District Wifi, but to connect we have to use a Username AND Password and there is no place to enter a Username. What do I do?


Normally, when you connect to WiFi hotspot, you select the SSID (sub-system ID) and use the password for SSID. Some sites (like your school) put another layer of security on top of that.

Do you know the steps for connecting a laptop to the school WiFi and if so what are they?


Yes, to connect we have to enter our district username and password.


do you do it in a browser? I need more details/specifics


yes, we enter it in the browser from the desktop, but when we go back to the game it won’t connect.


After you enter it in the browser can you go to any sites like google?


Can you find out if you use 802.1x with PEAP?

If so you can try what this guy did https://www.raspberrypi.org/forums/viewtopic.php?f=36&t=111100