Vanishing piper program



My daughter has completed the missions but was using creative mode and really enjoying the experience. Last weekend when she went to use it piper wouldn’t load.

Looking at the properties and the command path it would appear that the folder, unless hidden, has vanished. Can you please tell me how we can restore the program?



When you boot the pi, does the video start?

Also from the desktop, if you run the file manager, is the Piper folder missing? (that would be strange)
Is there anything in the trash?
Can she remember how she shut down the Pi? i.e. - did she use the shutdown command or just poweroff the battery?


Hi @Paul

could it be possible that she just powered it off instead of going the main menu then powering it off


@pipergamer - If you notice, that is what I asked. If you just shut off the battery, it can cause corruption of the SD card and you will have to re-flash it. You should always select the power off from the menu and then wait 30 seconds before turning the power off.


Thank you Paul,

How do I re-flash the SD card?

As she has probably done this numerous times, today when I have decided to review whether I can fix this or throw it out, we are getting lots of scrolling text and eventually, after several minutes we are getting black screen. Then nothing.


Hi @JnM_Lyons,

Sorry to hear! Please click the link here for instructions on how to re-flash the image. After you do that and click the update button, your daughter will be up and running with the latest software version!


  • Jordan


Hi Jordan,

thank you for the suggestion. Were you were hoping that i would find the information below in the link?

LATEST VERSION (ver2.0.2, 02/03/2017):

Piper ver2.0.2 image (7.40GB) found here409.


The Piper ver1.0.6 FULL image (7.40GB) found here231.

The Piper ver1.0.6 COMPRESSED (3.37GB) found here164.

The Piper ver1.0.3 image can be found here182.

The Piper ver1.0.2 image can now be found:

Complete .img file (7.95GB) here87.


Compressed .zip file (2.49GB) here128.

These files are stored on Google Drive so the bandwidth and reliability should be solid.


So I have tried to download the following:

  • Version 2.0.2 - it downloaded 7.19GB but then an error message was produced.
  • Tried it again and got the same result.
  • So i tried 1.0.6 full image. it too downloaded 7.18GB then produced the same error.

I switched my approach and tried the compressed version of 1.0.6. It downloaded the whole file. But when i tried extracting it I’m told it is not a gz file! I attempted to extract the file using both The Archiver (newly downloaded) and also a terminal version using gunzip as seen through

What is the next approach here? I have wasted an awful lot of time this weekend trying to resolve this problem. Sending me from one link to another isn’t really helpful so i’d like the next suggestion to be sent directly to me.

if it makes any difference - I’m using macOS High Sierra
Thank you



Hi @JnM_Lyons,

I’ve just run some tests on the image files available for download and there were no error messages produced when downloading the full images. Have you double-checked that you have at least 8GB available on the machine you’re downloading the files on (since you received the error message on two different files but both at approximately 7.18GB)? In addition, using the command “gunzip v106_piper_image.gz” successfully uncompressed the file (but likewise there would be an issue uncompressing it if there isn’t enough disk space on your device).

If you are still unable to download an image and re-flash your SD card, then we would be more than happy to send you a new one with the latest image!


  • Jordan


Still not having much luck!

Downloaded v202_Piper_Image at work. This was successful

Tried copying to personal hard drive 1TB -NTFS format but got message too large for destination.

Purchased a new 32GB USB FAT 32 format, to keep a copy in case this happens again, also purchased new micro SDHC 32GB for the new image.

Returned to work and tried to transfer image to USB. Got message “file is too large for destination file system.”

Tried copying direct to SDHC card and got the same message. I’ll work with my companies IT personnel to see if they can assist but in the meantime do you have any suggestions? Ideally I’d like a copy on USB in case this happens again. In my experience kid switch of power not Shutdown as seems to be required here.



Hi @JnM_Lyons,

As recommended in the ‘how to’ thread containing the image files, please try using the program “Etcher” (download link here) to re-flash the corrupted micro-SD card with the v202 image you successfully downloaded. Regarding storing a local copy to your USB stick, please try right-clicking on the removable drive in finder/folder view and changing the “file system” format options to NTFS and the “allocation unit size” to default allocation size (as demonstrated here).


  • Jordan