Updating my Piper


#1

Please post here if you are updating your Piper levels and the community will be happy to chime in and help!


Piper Software Update! Version 1.0.5
Piper Software Update! Version 1.0.4
Piper Software Update! Version 1.0.6
Piper Most Common Fixes
Piper Software Update! Version 1.0.3
Piper Software Update! Version 2.0
#2

hi Tommy, I reckon you meant “having problem updating”?

The OS on my Piper is connected to Internet (both wired and wifi) and yet Piper software can’t connect to Internet to download the update for more levels. Please suggest what I can do.

Thanks
Khanh


#3

We just updated our Piper. We did not see the date issue, however we did not have to wait for two minutes to see the status bar move (in fact, we never saw it move at all, and the update was very fast), and the screen was frozen when we rebooted after the update. We rebooted again and the issue seems to be resolved. My son is playing the levels now, and I will chime in again once he gives me some feedback. So far he says that he loves the rebuilt design.


#4

My brother keeps trying to update his Piper, and it seems that it does not work. I am not sure if he finished the Funky Fungi level, and that might keep him from updating, but the update button is not grayed out, so I assume it is a problem with something else.


#5

Hi @LionCoder,

Can you please be a bit more specific about what doesn’t seem to work? Does the update window show? If so, does the date in the updater show the current date? Does the progress bar begin to move after approx 2-3 minutes (it will appear as if nothing is happening)? In the options menu, does the version number at the bottom left say “1.0.2” or “1.0.3”? Thanks and please keep us posted!


#6

My problem is that whenever I try to update my daughter’s piper, by clicking update, nothing seems to happen, there is no date at all. There is a red light glowing inside the WiFi part of the piper, so I am assuming I am connected correctly to the WiFi, so I didn’t know if that is the problem or not. My piper seems to be frozen up completely. Thanks for any help! @Camicazi


#7

I’ve got the same problem as that reported by people above, the update doesn’t seem to proceed, no matter how long I wait.

I’ve tried a few networks to no avail.
I can see that the box is trying to reach piperwebserver.elasticbeanstalk.com which seems to resolve to a server on amazonaws.com but there is nothing there and the attempt ends up in a 404. Maybe it would be usefull to display a failure to the user after a little while rather than just wait indefinitely…

I can share some logs (or collect more specific ones) if that helps, let me know…
I have a very frustrated 7 year old who is desperate to be involved in the beta!


#8

Hi @Camicazi,

When you try the update here: Piper Software Update! Version 1.0.3 you don’t see any update window appear, correct? Does the main menu background show Piperbot looking down at his chest (with a WiFi symbol)?

Thanks


#9

Hi @Matt,

Does the update window show? If so, what is the date displayed in the top bar? If the date is current, then (depending on your internet connection) you’ll have to wait up to 2-3mins for the progress bar to start moving.

Thanks


#10

@jordan Hey, thanks for getting back to me…

Yes the update box comes up and shows today’s date.
Nothing happens though… I can leave it in that state for more than a day with no change whatsoever… I’m on 100Mbit/s at home and much more than that at work where I also tried.

I think I’ve cracked it though (well at least my particular problem)… I looked through the code and could see a git.exc.GitCommandError exception triggering… I figured some update had not completed properly on a previous occasion and left some git locks in place, preventing further update… I just did:
rm -f /home/pi/piper/.git/ORIG_HEAD.lock

And then the update worked fine… My kid is only allowed to play at week ends, but I expect he’ll be delighted and will be on his best behaviour all week.


Piper No Longer Boots AFTER Updating - Fix!
#11

@Matt

Brilliant detective work there and thanks for posting!

Cheers


#12

Thanks for the tip. That lock file does not exist on my system, but I am having the same problem. Update hangs up perpetually… can you tell me what you used or what file you examined to look through the code and see where it is hung up? My wifi is good - posting via the epiphany browser on the piper now.


#13

Hi Superfly,

I checked how things were going in updater.py
I can’t remember exactly where the file is (and I can’t look it up as my kids are in bed now).
Basically, I made some mods in that file to figure out what exception triggered, (it first checks connectivity, and then a bunch of other things). I had to be a bit ruthless to be able to run it on its own.
When I figured it was a git wrapper exception, I extracted the git command which I then attempted to run standalone, and that showed up the lock issue.

Error handling is a bit light in that bit of code and basically any exception there will leave the GUI hanging, so indeed there could be a number of root cause behind that behaviour…

Hope this helps.


#14

When or where are the links to new images going to be posted?

Thanks for the update.


#15

take a look at the first post of this thread,


#16

Hi,

I do not manage to find the link to the 1.0.5 image … Links in the first post send me into circles.

Can you help please?

Thanks


#17

Hi @schwarzes_krikri,

The best way to update your Piper is to download the v 1.0.3 image and then go through the updates while connected to Wifi. That will allow you to have the most stable version.

Thanks!