Update Repair script not working?

I am trying to run the “Fix to most Piper issues” update repair but getting some errors:

Repairing Piper (v2.1), please wait
   - <3 devs
8.8.8.8
Err http://mirrordirector.raspbian.org jessie InRelease
  
Err http://archive.raspberrypi.org jessie InRelease
  
Err http://mirrordirector.raspbian.org jessie Release.gpg
  Could not resolve 'mirrordirector.raspbian.org'
Err http://archive.raspberrypi.org jessie Release.gpg
  Could not resolve 'archive.raspberrypi.org'

Any ideas to what’s wrong here. Internet connection is fine.

are you sure you are connected to the internet?
go to a browser and enter ‘archive.raspberrypi.org’ and see if it connects. If it does then there might have been an issue on the server side so try it again.

1 Like

I’m getting the same error.
I’m able to get to the Internet, using the PI now to type this message. apt- get update connects to the repositories, but the piper update errors.
The error "Oops! Having trouble connecting to our update servers."
pi@raspberrypi ~ $ sudo apt-get update
Hit http://archive.raspberrypi.org jessie InRelease
Get:1 http://mirrordirector.raspbian.org jessie InRelease [14.9 kB]
Hit http://archive.raspberrypi.org jessie/main Sources
Get:2 http://mirrordirector.raspbian.org jessie/main armhf Packages [9,536 kB]
Hit http://archive.raspberrypi.org jessie/ui Sources
Hit http://archive.raspberrypi.org jessie/main armhf Packages
Hit http://archive.raspberrypi.org jessie/ui armhf Packages
Get:3 http://mirrordirector.raspbian.org jessie/main armhf Packages [9,536 kB]
Ign http://archive.raspberrypi.org jessie/main Translation-en_GB
Ign http://archive.raspberrypi.org jessie/main Translation-en
Ign http://archive.raspberrypi.org jessie/ui Translation-en_GB
Ign http://archive.raspberrypi.org jessie/ui Translation-en
Get:4 http://mirrordirector.raspbian.org jessie/contrib armhf Packages [43.3 kB]
Get:5 http://mirrordirector.raspbian.org jessie/non-free armhf Packages [84.2 kB]
Get:6 http://mirrordirector.raspbian.org jessie/rpi armhf Packages [1,356 B]
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en
Ign http://mirrordirector.raspbian.org jessie/main Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/main Translation-en
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en
Fetched 4,183 kB in 1min 12s (57.6 kB/s)
Reading package lists… Done

First try this. Open a terminal window and type the following:
df -h
and from the first line, what are the Size, Used and Avail?

second try it again. Sometimes the servers just have a problem and you can’t get to them. I did see a thread on the raspberrypi forums of someone having an issue the other day.

1 Like

Hi @JRingold,

Are you trying to run the update from the game menu screen or are you running the repair-script file that is downloaded as part of the “Fix to most Piper issues” thread here?

Thanks!

  • Jordan
1 Like

I am able to connect to archive.raspberrypi.org in a browser - so connection is verified.

But when i run the self-repair.sh script from the terminal i get this:

rsync: getaddrinfo: updater.playpiper.com 873: Name or service not known
rsync error: error in socket IO (code 10) at clientserver.c(128) [Receiver=3]

…and then a lot of fail statements.

E.g.
W: Failed to fetch http://mirrordirector.raspberrypi.org/debian/dists/jessie/InRelease

How is your internet set up where you’re trying to use the kit?

1 Like

Hello. Has this been resolved by anyone yet?
Thanks!

First off, why are you running the repair script?
What issue are you encountering?

1 Like

When clicking on any game mode, the machine crashes to the desktop and freezes. The machine is on the latest update and the Internet connection is working.

My suggestion would be to reflash the SD card. Take a look at this thread

1 Like