Update Error Message


Yes I was connected to WiFi. That was the first thing I check when I saw the computer was not doing anything. It would start out looking like the it was doing something (showing 20-30%) usage on the task bar, and then suddenly 0% after a few minutes. I would reboot and the same problem.


Thanks Jordan-

I was having this same issue. I entered the command you described - a window came up briefly that seemed to be trying to update, but then I was sent back to the command window with the errors attached.

But! After a few more minutes the other window flashed and I was able to launch Piper. I now have the 2.0 version, looks like some major changes. I would say the whole process took about 20 minutes. I also have fairly fast internet.

Could you let us know when the new update is ready? This one was really confusing.


Same issues here tried all the above. Final error is that the directory game/userData already exists.


this worked for me too


After I type in mkdir ~/piper/game/userData, I see this screen. Then I waited and reload the game, but the same error message popped up again and the game doesn’t load after the intro video.


Just wanted to update. One of the programmers reached out to me by email and was able to get our issue resolved. The update problem wasn’t enjoyable, but in the end the Piper folks persisted and got the issue resolved for us. Thank you.


@Nanostart could you try startng the game from teh terminal using ‘cd piper && sudo python start.py’ and let me know what happens.


Thank you, Paul. Here are screen shots.



did you upgrade the Pi as @JRingold said he did in his post in this thread? I’m trying to get a handle on what you have done. This the problem when multiple people post in the same thread…


I’m having the exact same issue he described. I upgraded the Pi based on the post from JRingold. Still can’t launch the game with any of the advice suggested here.


Hi @jordan,

It’s all good now.
“Make window managers treat panel as dock” is checked.
“Minimize panel when not in use” is unchecked. Display is also fine when checked and I may enable it later based on preference.



Yes I did. I did everything suggested in this thread. Thanks.


HI @Nanostart,

Can you please try the following in terminal, “sudo pip install python-uinput --upgrade” followed by [enter/return]


  • Jordan


Hi @jordan,
It did not work…
After “pip python.uinput --upgrade” and then “cd piper && sudo python start.py,” the same exceptions appear, except that where instead of “0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded,” it now says “0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.” I proceeded to use apt-get update and upgrade again. Running start.py, the same exceptions again except now it states, “0 upgraded, 0 newly installed, 0 to remove and 0 upgraded.”


I continue to have the exact same issues as described by Nanostart. This is incredibly frustrating. This was a Xmas gift for my son, and I’ve spent more time trying to fix this update error than he has had actually enjoying it. Instead of getting him engaged in computers and programming, its created the opposite effect. He’s even lost interest in sitting next to me as I try fix it. Please help! If we can’t get this fixed, please issue a replacement. I seem to be in a small group that is still having the problem.



I am right with you. It is saying “Requirement already up-to-date: python-uinput in …” still getting Oops message!


Hi @jjporter1979,

Sorry for the inconvenience! The latest v202 image was posted today if you’d like to burn a new image on your SD card. You can find the new image and installation instructions here.


  • Jordan


This seems to have worked. Thanks for the quick reply.