Update Error Message


#21

Same here. Same goofy error message over and over. Clicking okay does nothing. Waiting an hour or more after clicking okay does nothing (except run down the battery). Typing the various commands produces screens full of error messages and code, but no access to Piper.

This Piper was a gift for my son, who only had 2 days of use of it (building it) before being directed to do the update. It hasn’t worked since.

We’re all very frustrated!!

I would appreciate it if the Piper folks would just say “We don’t know what’s wrong - we’re working on it - we’ll post when there is a real solution.” I don’t want to be given any more random commands to try. (I’d rather wait a few days and then do ONE thing that WORKS.)

Thank you.


#22

Hi @amaier,

If the game didn’t load shortly thereafter, please open a terminal and type “sudo apt-get install python-pyqt5” followed by [enter/return]. After it finishes (you see lines stop showing), please close the window and launch the game.

Thanks,

  • Jordan

#23

@jordan

This worked for me. I had to put in “sudo dpkg --configure -a” first. i was prompted once for a y/n to use space after it installed python pyqt5. Everything ran smooth and the program is running now.


#24

I’m having same error message but the fixes suggested won’t work. Everything was working fine for two weeks and the issue popped up at the same time others are reporting.


#25

Did this but then I got prompted to use ‘apt-get autoremove’

I did that and then it said Permission denied.


#26

you have to use ‘sudo apt-get autoremove’


#27

I’m in the same boat here. Followed all of the steps suggested and and was finally able to get the following statement after running:

sudo apt-get install python-pyqt5

I am told “python-pyqt5 is already the newest version”.

But I still get the above “oops” error when trying to run n piper. Any other suggestions??


#28

I was able to get the game to work after performing a number of system level updates.
The game seems a little different than I was expecting, but seems to be functional. I will play a bit this afternoon or tomorrow and let you know if there is something that doesn’t work.

Here was what I did to get it working:
type “sudo apt-get update” followed by [return/enter]
type “sudo apt-get dist-upgrade” followed by [return/enter]
type “sudo apt-get autoremove” followed by [return/enter]
type “sudo python ./piper/start.py” followed by [return/enter]

I had to Right-click on the taskbar and select “Panel Settings”. Click on the “Advanced” tab, and check “Minimize panel when not in use” to get the taskbar to hide so it wouldn’t take up some part of the screen when playing.


Menu Missing and Update Error
#29

Yes - I’ve also noticed that window sizing / maximizing is a bit off throughout the system since this problem emerged.


#30

I’ve tried everything suggested above and kept getting the same error message. I’ve been working with piper for over an hour. Now it just shut off because the battery is dead. Very frustrated about this. My kids were waiting to play the game and now a big let down.


#31

Had similar issues as described earlier in the thread.
But got the game working again with:

sudo dpkg --configure -a
sudo apt-get install python-pyqt5
sudo python ./piper/start.py

But the game is still not really playable because the text/captions are coming up “behind” the main play screen;
so not readable.

Can anyone suggest a fix?

Also, I’m not able to minimize the taskbar even with “minimize panel when not in use”.


#32

I too have tried all of the above things and still the same problem. My kids are losing interest fast in these computers. Hard to play with them to learn programming when you need to be a techie just to use them in the first place. I hope Piper can post some instructions here for fixing the situation.


#33

Hi @Karlo,

In your Panel Preferences, please try only checking the “Make window managers treat panel as dock” and leave all other options unchecked (including “Minimize panel when not in use”).

Thanks,

  • Jordan

#34

For this specific error (“no such file or directory: game/userData/lastAptGetUpdate”), try typing into the terminal.

mkdir ~/piper/game/userData
then hit enter.

And then try starting the game.


#35

For most cases, relaunching the game another time (with the Oops error message) and waiting some amount of time should lead to the game popping open once everything is installed. It doesn’t matter if you hit OK on the Oops message or not, just wait and if it takes too long then try restart the game.

Greg


#36

Not in my case. Did everything and the error message kept popping up and the game would not load. I had the same screen as amaier posted 6d ago (no such file or directory…), so I tried to make directory as your previous post suggested, but it said the directory already existed. Then I did what you suggested in this post, rebooted and waited, nothing happened after almost an hour. Rebooted again and waited, still didn’t work.

At this point I have a piece of very expensive non-working so-called computer sitting on the table causing extreme anxiety and anger. I bought this so my kids can learn to love computer and programming, but it’s having the opposite effect at this point. We didn’t even get past the third level and then the update rendered this thing useless. I begin to think I made a big mistake on buying into this. I could have spent the same amount of money and bought a simple laptop that actually works.


#37

Is someone at Piper working on a new update to correct this? It seems pretty clear that there was an issue with the last package and it would be great to know if a remedy is on it’s way.


#38

Yes, I have been working on reproducing and fixing these issues, which we did not see prior to releasing the update. Your posts do help and I appreciate you helping us figure out what’s going wrong.


#39

Are you connected to the internet when you open the game? If not, please connect to a wifi network through the taskbar.

I have reproduced that exact error (“no such file or directory: game/userData/lastAptGetUpdate”) and running

mkdir ~/piper/game/userData

and then waiting for the updates to install during the Oops message fixes it (given that you’re connected to the internet).


#40

For those that have a different error when they type “sudo python piper/start.py”, please post a picture of your terminal right after running that command and I will help you (and any others that ran into the same issue) fix it.