Update Error Message


Hi. Logged into Wifi to do the first update. The message we are getting reads,

“Oops! An error occurred during the last update. Now finishing the update. This process may take 10 minutes to complete, depending on internet. Please wait…”

Am still waiting and waiting and waiting. Our internet is very fast. Please advise on how to fix this.

Thank you.


It takes a good 10-15 minutes to do the update.

Try this, open a virtual keyboard (Menu->Accessories->Keyboard) then open a terminal window. At this point you will need to move the terminal window a bit to see the keyboard. Type ‘top’ and clck teh ‘Ret’ key.

This will show you what is going on. Look for the user PI and see if the command it’s running is ‘pcmanfm’ or ‘apt-get’. If it is ‘apt-get’ just watch it till it finishes and then reboot. If it is ‘pcmanfm’ reboot the pi and see if you have the updated version of Piper.


Thank you but I don’t see either of those commands.


When you saw the ‘Oops…’ message and clicked ok, can’t you still see the desktop? (I can’t remember if the desktop gets hidden or not)


I’ve been having the exact same problem with the “information” message. The entire message reads as follows:

“Oops! An error occurred during the last update. Now finishing the update. This process make take 10 minutes to complete, depending on the internet. Please wait…”

I’ve had the Piper sit quietly for the last hour and the CPU usage monitor setting remains mostly at 0% and spikes to 2%.

Following the above instructions in the terminal, neither “apt-get” nor “pcmanfm” appeared at all.

Is there a way to download and perform the update without loading Piper from the Raspberry PI GUI?


@cprtrains did you click the button on the message?


Yes. No effect within Terminal or to Piper.


Try a reboot nd see if the update took



Yes. Same result and message each time.


Try again, the Piper guys just pushed a new update that will show a graph of the update


Hi @cprtrains,

Since the newly added feedback requires you to be able to update for the new change (which you cant currently do), in order to see the progress of the installation you can open a terminal, type “cd piper && sudo python start.py” followed by [return/enter].

Thanks and please keep us posted!

  • Jordan



Which part of the very long text would best be shown here? There was a string of error messages, followed by the same dialogue box as before.


Are there spaces after sudo and python?

Have tried different versions but am getting: command not found or not such file or directory.


This same thing is now happening on both of our Piper units.


Hi There,

The same thing has been happening to me - i keep getting the error message about an update taking 10 mins and nothing happens. I have tried the fixes mentioned above and nothing works - when i typed in the code in terminal i get the same error message Ooops! An error etc and nothing happens?

Please advise.




Hi guys,
I have the same problem with the update. I am trying to prepare 15 of the Piper Kits for my class, which starts the next week and I ran into this error now. I also tried the command to see the progress. It starts, but after one minute it stops with a lot of error messages.


Can you please provide a screenshot of the output?


  • Jordan




I, too have tried all of the suggestions to date and am at a complete loss as to how to proceed. On the one hand, tackling this problem is so much like owning a PC and having to constantly reinstall the OS, so its a bit of a learning opportunity for my son. On the other hand, it’s also producing the same level of frustration and irritability with not being able to find a logical solution and the support from Piper is lacking. The Piper is absolutely a brilliant concept and quality product from a hardware perspective, but this software glitch and absent assistance is very disappointing. I really hope that someone from the company can put forward a solution as I’m out of ideas.