Unable to enter cheesteroid level - flashes and hangs on "loading..."


#1

We completed the base kit and completed the Mars level with the first L/F/R buttons which are working fine.
We got to the point of seeing the pre-level video for the Cheesterioid level. Whenever I choose “story mode” and select the Cheesteroid level the screen shows the level screen for a second, then it goes away, and I’m left with a “Loading…” status on the top of the screen, and the desktop showing (with Piper and Code icons), and it stays that way forever. Restarting produces the same results. Can’t seem to get any further…
thanks


#2

Have you run an update yet? From the main menu select the gear icon and at the bottom left you will see a version number. The latest is 2.4.4 - if you are not at it. please update - it is a bug fix release.


#3

Yes, I ran the update first as instructed.


#4

How do you shutdown the Pi? Do you just power off the battery?

My guess is that you do and that when you did, the Pi wasn’t finished writting out files or cleaning something up and you have corrupted a portion of the SD card (It can be re-flashed)

Can you see if you can get into PiperCode?

I’d like to ask one of the developers about this but they won’t be avaliable till Monday. Meanwhile if you are reall anxious to continue there is a file you can edit to mark the level completed so you could continue on.

You wil need USB keyboard to plug into the Pi if you want to try it. Please let me know and I’ll write up the steps for you.


#5

I didn’t shut down the Pi the first time until a good 45 mins of being stuck on “loading…”
I tried Erase Player Data and re-did the Mars level, but then the same thing happened again.
Sure, I can get into Code w/a keyboard if that helps.


#6

Ok, first try running the repair script. Go to this link and follow the steps and see if that works,

If it doesn’t then let’s try skipping that level

  1. Attach a USB keyboard and exit to the desktop.
  2. Once there open a terminal window
  3. type in:
    sudo nano /var/lib/piper/userData/playData/levelsCompleted.txt
  4. move the cursor down to the line:
    Cheeseteroid: 0
    and change the 0 to 1
  5. press ctrl/x then y then press the return or ‘Enter’ key

At this point you should be able to skip over that level. But don’t be surprised if you might run into other issues.

If you do then re-flashing the SD card will be the way to go. Follow the directions at https://www.playpiper.com/pages/software-update#SDcard