Treasure Hunt LED will not light


#1

I am trying to complete the Treasure Hunt level but I cannot get the LED to work. I have tried changing wires and LEDs and also moving them around in the mini breadboard. Can anybody help please?


#2

Have you tried reversing the led? A led is a diode and diodes only let electricity thru one way, so it is plugged in backwards it will not light.

Also have you tried another led?


#3

Thank you Paul, I have tried all the LEDs both ways round. It’s very annoying


#4

Can you post a photo of the breadboard and the wires going to and plugged into the gpio pins?


#5


#6

Could you go check the version of Piper you have. From the main menu, pick the Gear icon and at the bottom left of the screen (in tiny font) you wil see the version number. If it is 2.4.1 go back to where it instructs you to build the led detector and look at the wiring and compare it to yours


#7

Hi Paul, it’s version 2.2.1. I think we followed everything correctly. Do you have any ideas? Appreciate your help!


#8

As I said, go back to the level and compare the way you are told to do the wiring woth what you have. What difference do you see?


#9

Thank-you Paul, have reset the wiring now correctly and we’re up and running again!