Stuck in "return to the cheestroid"


I’m stuck trying to get through the level “return to the cheestroid” can anyone help me?


HI maxackroyd! I’ve finished the game and can help. What is the part your struggling with??



I am stuck as well.

  • For one, I am not sure what I am supposed to do. I have installed the two buttons and I can get the “action blocks” to multiply. But then what?

  • Also, when I am in the mode that shows how to assemble the buttons, one of the buttons shown on screen keeps moving without me touching the real button. I tought about this being caused by a loose contact, but can’t find anything.

Any hint would be highly appreciated!


@LenaKonst - are you stuck in the ‘Return to Cheestriod’ level or somewhere else?

Which color button is moving with out you touching it?
Can you take a picture of your button pad and the GPIO pins on the Pi and post them to a reply?


Hi Paul

It was a week ago, but I am pretty sure the point I (my daughter, actually) got stuck was after the return to the cheeseteroid.

It is not one of the colored buttons used to move around which is toggling, but one of the tiny ones one mounts on the breadboard.


Again a photo of the bread board and wiring would be helpful.

Did you try taking the button out and inserting it into the breadboard again? you might want to take a pair of needle nose pliers and straighten teh legs of the button before inserting it.


Hello again,
thanks for your promt replies, I really appreciate it!

Below two pictures. On the display, the button in the back to the right is going up and down at irregular intervalls without me touching the real button.

The legs of the button are not bent sideways or so and apper to fit nicely into the board. I tried exchanging the button to another one to make sure it is not broken. I also tried the same buld-up at another place of the breadboard to make sure there is not a wiring defect inside the board.

Best regards
Felix / LenaKonst


Did you try using a different wire?


Yes, I also tried several wires. The contacts on the Raspberry Pi side also do not look bent or anything :frowning:


I’m sorry, I should have asked this right off. Does the button randomly activate while you are playing the game or is it only while in the construction?


Hi Paul

Thanks for your continued efforts to help us!

When I’m back in story mode after installing the second button, the game sends me straight back “Let’s try building another button at that crafting table”. As if the second button wasn’t there at all. Then again: Back in crafting mode, the yellow current is shown to be running through all three wires.

I just did that and now I’m faced with a new phenomenon: I can’t get out of the crafting mode. Pushing the buttons doesn’t help. Neither does emulating pushed buttons by just short-circuiting the wires.



Hi Felix & Lena,

The reason that button is compressing in piping mode is to indicate a push, it’s not reflecting any behavior that you are doing.

It sounds like you have successfully wired your buttons so I would not return to piping mode and risk getting stuck! Keep moving through the level and use the buttons to move blocks and create blocks so you can pass through.

Thanks for the help @Paul :blush:.



Thanks Tommy

You are right: There doesn’t seem to be anything wrong with the buttons.

That brings me back to my first point however: I really don’t know what to do. The left button makes the blue action blocks expand. The right button makes the red action blocks stamp out blue blocks in their way… But so what??

Digitally challenged


Hi @LenaKonst,

As you’re figuring out, the buttons (and switch) are used to clear the path to the exit. Sometimes you only need to build blocks to make a path (blue blocks), sometimes you only need to erase blocks to clear the way, and sometimes you need to do a combination of BOTH (e.g., draw blocks for a path for which some blocks may then need to be erased to create stairs that the player can reach). The switch mimics holding one of the buttons down to maintain a block types action (e.g., in one scenario the switch is turned off to stop continually drawing blocks so that the red action block button can erase some of them to help clear a path (otherwise the blocks would continually draw, blocking the path)).

I hope this helps and thanks for the post!

  • Jordan


My digital-native daughter has saved the earth!
I can’t tell how she did it, but somehow she got through the last level.
A big thank you to everyone who helped us along.


Awesome. Congrats to your daughter!


We have had a bit of a break, just coming back and still stuck in the cheestroid, and still not getting it! any tips anyone, have taken all of the above on board and keep ending up back at the crafting table, even after getting through a door ?!?


Hi, sorry we never responded, have been doing other things, back now and still stuck! keep looping back to the crafting table in the cheestroid… frustrated!!


What version of Piper are you running? (from the main menu, select the ‘nut’ icon on the top right. On the next screen - at the bottom - you should see the version.

If you are not on version 2.0.2, do an update to get to the latest and the try again.

When you say you keep looping back to the crafting table, do you mean you get lost as you are making your way thru and end up back at the crafting table? I know I had that happen to me getting turned around a few times - it can be frustrating. The latest version is a bit easier. I’ sing you "…follow the yellow brick road…’ but that wouldn’t help since the cheesed is mostly yellow, so instead I’ll sing ‘…follow the icy blue road, follow the icy blue road…’ :grin:


I am also having trouble with this level I dont know where to go after I built the second button… is there a walkthrough available ?