Sound is working, but no speech, no sound in movies


I’m confused. Shouldn’t the in-game movies and instructions have speech? I’m only getting subtitles, and the occasional “bong” sound. The instructional movies also make a “click” at the start and end, and a hiss while they play through.

The startup movie has sound, so I’m guessing this is something lost in the audio codec.

I’ve done an update [edit: and reboot], followed by “git reset --hard c1cbf05 && git clean -f” as root in the “~/piper/” directory, and another update which it claimed wasn’t necessary. [edit: after rebooting again, it wanted to update again, so we wait again … later: two updates in a row now? This is getting silly, and I have a very annoyed child waiting on this. Much later: phantom update, nothing to do but wait again. Back into his game, no change. Bonks and beeps, but no typical Minecraft sounds like footsteps, TNT explosions, etc. And still no speech, just subtitles. Let’s hope there’s still a problem to be fixed, because this isn’t what I was expecting.]

What else is there to check, please? Or isn’t there any speech?


Try running this in the terminal:

sudo git reset --hard master



No change, except more waiting. (What is it doing? The load is nearly 0% and yet nearly every reboot is met with the same 8 minute wait for to show the game menu.)

amixer cset numid=3 1

You’re not preventing audio from going to HDMI. You’re leaving the audio mixer in auto mode (0, as the last argument) when it should be 1 for line-out, and definitely not 2 for HDMI.

This lets audio get routed to the line-out speaker now for the movies; but there’s no in-game audio such as typical Minecraft sounds, only the arpeggio when a new subtitle appears. Is this the expected behavior now? Again, my question above which you didn’t answer: Or isn’t there any speech?



Yes, there is speach during the movies.

Please try the following:

open a terminal window and enter

sudo nano /boot/config.txt

and scroll down till you find

 # Uncomment some or all of these to enable the optional hardware interfaces

and add the line


so you will have:

# Uncomment some or all of these to enable the optional hardware interfaces

Press CTRL-X, then ‘Y’ and press enter to save the changes
and reboot and see if you get sound


I don’t believe you guys are correct. The sound is working because when the subtitles show up it bongs at you. The sound also works in the first level or so, but stops afterwards. I made a comment to them about it as I figured they just got lazy and quit doing it because it took so much extra development time and the response I got pretty much backed that up. So I don’t personally thing there is any sound in the further levels.

My son is 5 and doesn’t yet read so I just sit behind him and read the messages and let him play and figure out the game. Would be nice to have the mouse talking throughout the games and levels as he was really liking the mouse, but would rather have more levels as he’s moved past the character and seems to be really digging into the process anyway.



Glenn, you are right, I misread the original post (I’m blaming my head cold) and thought he didn’t have it in the original video at level 1.

However if you want to exit Piper and go to Youtube in the browser, you do need to do what I said in order to get audio.


I’m getting sound in the Pipercraft program but not anywhere else (Scratch, browser/youtube, etc.). I’ve added “dtparam=audio=on” to the config.txt file but that didn’t seem too fix the issue. I’ve confirmed sound is turned all of the way up in both the youtube video and on the computer and have tried both headphones and the speaker with same result. Any suggestions would be very welcome. My son would like to use his Piper for other than just the included pipercraft program but without sound it is somewhat limiting. Please let me know if more info would be helpful. Thanks!


Hi @weberrow,

Have you tried forcing the audio through the 3.5mm headphone jack via raspi-config (we default to this on boot but just in case)? You can find the instructions here, but instead of choosing “0 Auto”, choose “1 Force 3.5mm…”.


  • Jordan


That did it - thanks Jordan! Not sure how the audio was coming through the headphone jack for Piperbot only before but it’s working for all of the programs now - son’s a happy camper. Thanks again.


And that’s exactly what I suggested above.

amixer cset numid=3 1

Why is this not the default in the build, guys?

To answer weberrow’s question, the reason part of the audio is not coming through the jack is because it’s routing it automatically. For movies, it assumes it has to go to the HDMI output. For desktop/ui sounds it assumes headphone.


Hi @Rich,

We do default to this on boot (via a configuration file) so it’s unclear why it wasn’t being set in this case. Thanks for your posts/help in the forums!

  • Jordan


This all looks good. But the Piper doesn’t have a keyboard…never mind. Just not obvious


Hi @Jmiyaku,

There is a virtual keyboard located in the Desktop environment if you do not have an external USB keyboard to use. Please navigate to Menu --> Accessories --> Keyboard to find it.


  • Jordan


I have tried the

amixer cset numid=3 1

solution and still can’t get anything but the random beeps past the main movie with speech. I’ve also tried Pandora through a web browser to test audio output through the 3.5mm and it doesn’t work. I’m curious why the startup has sound going through 3.5mm, but nothing else, even web browsing sessions.

Any ideas of anything else to try to get sound working? I can reply back with output of config files if needed.



  1. What model Pi do you have (it is on the Pi just below the GPIO pins)?
  2. can you go to a terminal window and type

cat /etc/os-release

and post the results


I tested again and did get pandora working, so I’m not sure why it wasn’t working earlier as I haven’t changed any settings since then. At this point I get the startup movie sounds, Pandora in a web browser, and the “alert tone” when doing the Minecraft levels. I get the music tones from the Pip Hop song creation level as well, but no in-game sounds or speech past the first level. I also tried launching minecraft from the command line without the Piper front end and don’t get any in-game sounds.

Is there a video out there of what sounds to expect from the gameplay?

1. Pi 3 Model B v1.2
PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"

NAME="Raspbian GNU/Linux"


VERSION="9 (stretch)"







Hi, the sounds in Piper are limited. While there is no sound of footsteps you should hear a beep each time a text from Pip occurs on the screen. There is no sound with the portal video or tnt blowing up (though I wish there were and have passted that suggestion on). This is based on a very early release of Minecraft which is why some of the things you might expect, like getting a bow and shooting it, do not work - they were not programmed into minecrafft unntil later versions.


OK, in that case I guess sound is working as intended. I do get the beeps.