Set story mode complete

LOL. I got about halfway through the solution before I asked. I tried changing the unlockedLevels.txt to no effect, then I was looking through the python code where it seemed like this would work. Then I got impatient and decided to ask :slight_smile:

You’re right though, it is useful to know and will definitely help others out in the future!

Hello Jordan, the files structure of the latest Piper has change as far as unlocking levels. We have the same problem that the one mentioned above except that we ran the latest image of Piper and I don’t find the files you are referring to in the Piper folder/userData nor if searching the name of the txt files in the whole Pi folder/sub-folders. Would you be kind enough to indicate what i the new process to unlock levels and piper code activities too. I run makerEd workshops and need this feature, please.
Thank you

TYou are right the files have moved. As of version 2.4.4 the files are located at /var/lib/piper/userData/playData and the file is still the same levelsCompleted.txt

1 Like

Thank you Paul ! But I don’t have the files of the cheatsheet in that folder, only one, in PlayData, named levelsCompleted.txt. Inside there are written all the levels with 0 except building bot which was 1. I figured I had to edit all levels with 1 (binary true). But I can’t seem to be able to save the file. Pi says it can’t open the file to save (! it is open !). Any hint? The full updated procedure for educators/parents would be most welcome…
Thanks again for your support, it is indeed appreciated…

Being able to unlock PiperCode activities would be crucial to me too. thanks. Best

As of version 2.4.4 the files are located at /var/lib/piper/userData/playData and the file is still the same levelsCompleted.txt

Open terminal window and enter:

cd /var/lib/piper/userData/playData
sudo nano levelsCompleted.txt

When you finish making the changes press


and that should save the changes. To make sure enter

cat levelsCompleted.txt

and you should see your changes.

1 Like

Great, Thanks ! It worked just fine! Only the piper code activities still locked but I guess this is another procedure…

Let me find out and get back to you.

1 Like

Well I’m embarrassed about this since it is so easy. Open PiperCode and go to Setting where you will find an option to mark all projects complete.

1 Like

Ah! Ah! My bad too, I didn’t see the obvious! Thanks for everything Paul. Wish me luck: I’ll try my first Piper Code session tomorrow with the Kids Coding Club.

By the way, I’ve started to translate the slides of the Piper Curriculum in French. Where can I share it or who do I send it to so you guys can add it to your ressources?

By the way, I’ve started to translate the slides of the Piper Curriculum in French. Where can I share it or who do I send it to so you guys can add it to your ressources?

That’s wonderful, please email and share what you have done!

Will do ! thank you !

Just a note Paul: I had a very strange bug following this unlockalllevels sudo > Before the sudo, all games worked fine. After sudo, in every SD Card I had done the process onto, the left and forward button on the GPIO stopped working. After reburn of the SD card with all level locked, everything is fine again. If I redo the sudo, bug comes back again. I don’t know why there is a link between 2 very different operations, but there is one, for certain. I would be very curious to understand the final say of that story and to know a better option (without bug) to unlock all levels…

What version of Piper? If you start it up and click the gear icon you will see the version number down the bottom left in small letters

Did you try the SD card in another pi tosee if the same problem occurs?

Thanks Paul for replying so quickly. Last version of piper Os I believe (2.4.5), with a 2017 piper hardware (with the green ball), and no I didn’t try another pi SD card engraver, because I never had problem with Apple Pi before and the problem keeps coming back after sudo on a working card, not after SD card burning. But I will try Etcher later on this week (I don’t have the pi with me right now). What do you suspect is the bug’s cause ?

What do you suspect is the bug’s cause ?
I have no idea, there should not be a connection that I can think of. If you have more that one piper kit, I want you to try swapping the cards between the two and see what happens.

I hope to try reproducing it tomorrow and I’l let you know what happens.

I’m not sure you understood Paul: the bug happened in all Piper Kit I did the sudo onto. In the middle of a Piper workshop, all of the sudden, all Pi had the same problem but one, which had a 16GB card and another manually unlocked system on it (the others were 8GB). So I was lucky at the FabLab they had 16GB spare cards and I burned them with the working OS. But I would very much like to solve that problem because those card should aren’t mine and I wouldn’t want to throw the 8GB cards away and save myself from having to buy new 16GB cards. I think for next update, it would be convenient to have a working script or button (very much like’ in pipercode) to let educators quickly switch and choose with level is blocked or not. I had two age group one after another on a weekly basis, and that would have been time saving to rapidly switch to each kid’s progress.

Sorry I missed that you did it to all the cards I’m reflashing a card now to test this.

I like the suggestion of having a script to unlock levels and I will pass that on.

I just reflashed and the controls work fine - what level did you test it with? I went right to BreadBoards Bluff. It is quite possible the code for the levelyou were at does not use thoes keys so they are not active…

Can you get the exact version of Piper by going to the gear icon? Thanks