Problem after update

I got a lot of info back but I’m definitely connected

So what IP number is returned for wlan0?
have you tried going to the desktop, opening the browser and going to ‘google.com’ just to verify you can access the internet??
What Piper version do you currently have? If you click on the NUT on the main menu you should see the version number at the bottom.

Hi @Paul,

I have something like 192.168.0.255 (if I remember well). I am connected to the internet (can access gmail, google, etc…).
I am running 2.0.2 and Piper does not see to want to upgrade to 2.0.3 (I read on another thread that there’s a more recent version named 2.0.3)…

How should I proceed to upgrade ?

Thanks,
Fred

@Tintin - The 2.0.2 IS the latest release as of today (3/6/2017) and it was released 2/3/2017.

Thanks @Paul !
and the next 20 characters…

?? I’m not clear what you mean by that?

My response was missing 20 characters. Thanks @Paul was not long enough to get posted :wink:

Envoyé de mon iPhone

Sorry, I’ve been away a few days.

I get 10.0.0.240 and I’m able to use the browser. Pretty sure I’m on the latest version

@Rhys - could you check which version of Piper you have running. From the desktop click the ‘nut’ (six sided object with a hole in the center at the top right hand side of the screen) and at the bottom of the window you should see the Piper version.

What is it?

Mine doesn’t show a nut. At the top right I have from left to right the wifi signal indicator, volume, CPU usage, time, and then the eject hardware icon

Please try the following and see if Piper starts up

  1. Open a terminal window via the panel at the top.
    Type in the following:
  2. sudo python piper/start.py
  3. Hit enter.

Looked like a number of things happened and then I get the same response. Attaching an image that hopefully comes through. Does any of this make sense?

I’ve sent a note to the piper guys about this

Thanks Paul. Very much appreciated.

HI @Rhys,

Please try the following:

  1. open a terminal window via the panel at the top of the screen
  2. Type in “sudo apt-get install -y python-pyqt5”
  3. Hit Enter
1 Like

Hi Marc,

Have you given this fix a chance?

You might find it useful!

Tommy

So I’m getting this same error (and same issue in getting here re hanging at that “20 min update” message while it does nothing)

I tried the fix posted by Tommy on March 10th and I get the following errors. See screenshot.

I have also tried the other fix mentioned in this post [Devs] Fix to most Piper issues and I get a variety of errors there too.

Please help!!! I can start another thread or contact directly if necessary. We’ve pretty much not been able to play anything because we can’t even get started :frowning:

afteraptgetinstall_attempt

did you try running
sudo dpkg --configure -a
as the message tells you too?

Now that, I did not do. Will try tonight. TBH, I wasn’t exactly sure if that meant “Run This Command Now” or “You need to do other stuff and here is a bunch of letters and symbols that I’m confusing you with.”

But in retrospect, now that you’ve pointed it out, it seems fairly obvious that I should have just run that command.

Will update later.

So running that helped but now there are a score of other issues. Will deal with later.