Problem after update


Information bar says:
completing the last update. This may take 20 minutes to complete, depending on internet. The game should start when the update completes.

Problem is it never starts and I’ve waited as long as 45 minutes with 100mb speeds. I’ve restarted a couple of times and tried to copy a couple of the suggested terminal recommendations with no help.

Any suggestions would be appreciated.


Are you sure you are connected to the internet?
exit piper to the desktop and open a terminal window and type’ipconfig’
do you see a valid IP address for wlan0? something like or


I get command not found but when I go to the wireless icon it shows everything configured except when it gets to eth0: Link is down


Arugh…it’s ‘ifconfig’ not ‘ipconfig’


I got a lot of info back but I’m definitely connected


So what IP number is returned for wlan0?
have you tried going to the desktop, opening the browser and going to ‘’ just to verify you can access the internet??
What Piper version do you currently have? If you click on the NUT on the main menu you should see the version number at the bottom.


Hi @Paul,

I have something like (if I remember well). I am connected to the internet (can access gmail, google, etc…).
I am running 2.0.2 and Piper does not see to want to upgrade to 2.0.3 (I read on another thread that there’s a more recent version named 2.0.3)…

How should I proceed to upgrade ?



@Tintin - The 2.0.2 IS the latest release as of today (3/6/2017) and it was released 2/3/2017.


Thanks @Paul !
and the next 20 characters…


?? I’m not clear what you mean by that?


My response was missing 20 characters. Thanks @Paul was not long enough to get posted :wink:

Envoyé de mon iPhone


Sorry, I’ve been away a few days.

I get and I’m able to use the browser. Pretty sure I’m on the latest version


@Rhys - could you check which version of Piper you have running. From the desktop click the ‘nut’ (six sided object with a hole in the center at the top right hand side of the screen) and at the bottom of the window you should see the Piper version.

What is it?


Mine doesn’t show a nut. At the top right I have from left to right the wifi signal indicator, volume, CPU usage, time, and then the eject hardware icon


Please try the following and see if Piper starts up

  1. Open a terminal window via the panel at the top.
    Type in the following:
  2. sudo python piper/
  3. Hit enter.


Looked like a number of things happened and then I get the same response. Attaching an image that hopefully comes through. Does any of this make sense?


I’ve sent a note to the piper guys about this


Thanks Paul. Very much appreciated.


HI @Rhys,

Please try the following:

  1. open a terminal window via the panel at the top of the screen
  2. Type in “sudo apt-get install -y python-pyqt5”
  3. Hit Enter


Hi Marc,

Have you given this fix a chance?

You might find it useful!