Power cables for battery and speaker? Battery is dead and isn't charging!


We have a dead battery upon opening the box and there is no power cable to charge it. Also, no power cable for the speaker so no audio.

Are these supposed to come with the kit??? Kind of odd that is shows audio in the ad, comes with a speaker, but has no power cable to turn it on.

Charged the battery and if we disconnect it from the power it dies. Really?

Also, once we get to play mode we, us adults who program, cannot get out of the UI to get back to the home screen. What the???

Super bummed about this Christmas present so far. Not impressed with the lack of help on Christmas Day either.


Hi @holly0228,

Yes, the kit should have come with a charging cable for both the battery and the speaker. In fact, they can both use the same power cable (which is also used to power the Rasp-Pi). Also, the middle mouse button will open the in-game HUD menu, allowing you to exit (among other options).


  • Jordan


We have hooked up our own power cable to charge the battery (not going to take apart the unit to hook up the 4 inch power cord that is attached to two other parts that again needs either a computer or adapter to charge the battery and must tear apart the computer) and even after letting it charge for 4 hours it shuts down after 8-10 min of use. Each time it will restart on its own minutes or hours later and it begins all over again even if you are at the button installation and have items on the circuit board installed.

I asked the question initially about the battery, but you didn’t respond. Is it supposed to come dead and then need a continuous feed of electricity to work? That doesn’t seem to be working either or letting it charge as it dies minutes into the game.

Super frustrated on Christmas with this product.


Using one charging cable to charge up not one, but two items is wrong. Along with that you have to tear apart what you have already installed. Plus it is 4 inches in length and has no adapter so you have to pull apart everything to take and charge it via USB to a computer or another adapter to a wall. That makes no sense.

This battery keeps dying. Read my other reply above. And that is with using the battery plugged into an AC outlet with continuous electricity. Still shuts down and reboots awhile later to begin all over again.

So, frustrated for my son that I could scream. All he got for Christmas was this and it doesn’t work.


Hi @holly0228,

You should not have to tear apart anything that you’ve already installed to charge the battery or speaker. After 4 hours, the battery should be at least half charged (if not 2/3 charged). I’ll send you a parts code to receive a replacement battery.


  • Jordan


Hi, Unfortunately we also have a dead battery straight out of the box. Charged it overnight and never moved beyond one blue dot. Once disconnected from the wall there are no lights at all (pressed the power button). Needless to say this has slowed us down quite a bit. John

Dead battery and cracked clear plastic frame on raspberry pi

Any info on how we can get a new battery would be greatly appreciated.


Hi @John,

Sorry to hear! I’ll send you a follow-up message with how to get a replacement battery.


  • Jordan


My battery arrived dead too! We were able to charge it but it died in about 10 minutes. Battery won’t hold a charge! Not a fun Christmas morning


Attachment available until Jan 26, 2018

We are absolutely at our wits end. We have bought a new battery and power cables for the speaker and the battery. We then allowed the new battery to charge yesterday. Today, we hooked it up and the game starts, but it didn’t save where we left off with the buttons so we began again for the hundredth time. Even though we select the same menu options we now get thrown into what we are guessing is creative mode, which we did not choose??? I have video attached showing you how we could not get the UI to work and keep options up for us to exit or it wouldn’t provide any options no matter how much we scrolled or tried to use the mouse. Rebooted. Finally able to start yet again. Everything seems to be working. We get to the installation of the blue and green buttons and install them, but the program refuses to move forward and tell us anymore. Then the audio dies. No speaker now. We begin guessing where to put the wires as per the program illustration and finally get those to work and then we encounter the blue screen of death and the computer crashes!!! SERIOUSLY!!! We are Apple Developers and this has been more frustrating than dealing with iOS 11 updates!!

We wanted this to work so badly for our son and he is again in tears as this is his ONLY CHRISTMAS present!!!

We’d like some answers before we ask for our money back and return this.


Click to Downloadhttps://www.icloud.com/attachment/?u=https%3A%2F%2Fcvws.icloud-content.com%2FB%2FAUAkIL8KW5ujhQDUqpDCMn9wvtifAchwRrT8OSs0tNsXLQSEyd91wkrp%2F%24{f}%3Fo%3DAgT9t4XuxYcJSO_rFPorYrXI5Vqn0rexhdcmw0_pNYy-%26v%3D1%26x%3D3%26a%3DBaFa9SWA9CpDAwXFQAEA_wHIAP9x0r7G%26e%3D1516988433%26k%3D%24{uk}%26fl%3D%26r%3D5237E988-3859-413A-B644-7F1F9CF02571-1%26ckc%3Dcom.apple.largeattachment%26ckz%3DA86F3C77-4F0D-471D-ACF8-B9E275DFBE78%26p%3D19%26s%3DS8yXwzoKTrv4zsR9fy6mgz8mjJc&uk=ikq0GIVO1U_fdULXxoDETw&f=FullSizeRender.mov&sz=28490307
28.5 MB


Hi Holy,

Thanks so much for sending the video and sorry for the frustration you’re having! It looks like somehow PIperCode AND Piper Story Mode were loaded simultaneously. It sounds like a reboot fixed this issue. Regarding wiring up the buttons, does the game still not progress past wiring up the green and blue buttons? Do you see the virtual current flow for the green and blue wires? Does touching the wires together work?

Thanks so much for your time and patience,

  • Jordan