Piper won't start PLEASE HELP


#1

Hi. My son (8) was working on Piper and he got carried away and didn’t notice the battery going down. So, Piper turned off on its own while he was playing… I know you’re supposed to properly shut it down but I was hoping it would be ok. I tried not to panic initially. We charged the power source for a few hours and tried turning on Piper again. It starts loading and then a black screen comes up with a white cursor blinking at the top left corner… And does not do anything after that… We’ve waited for 15 minutes but it’s still stuck… On Raspberry Pi there is a red light and a blinking green light.

PLEASE HELP!!! HOW CAN WE GET AROUND THIS?!


#2

Hi,
First off take a deep breath and let it out.

Try turning the battery off - or unplugging the Pi and plugging it back in. I don’t expect it to go any further than is does now, but it might clean itself up (one can hope).

I expect that the SD card has become corrupted :anguished: but all is not lost, you now have a chance to provide your son (how old is he?) with a learning experience (after all that is what Piper is all about right?)

You can try to re-image the SD card and/or get a new SD card and reimage it (I reimage SD cards on a regular basis). Before I tell you how to, let me ask you a couple questions.

  1. When did you get Piper?
  2. What type of desktop computer do you have?
  3. How are you/your son at following directions?
  4. Do you have an SD card reader?

Once you give me that info, it will tell me how best to proceed with you.

Paul


#3

Hi! Thank you for taking the time to reply! I contacted Piper Support and they will send us a microSD card replacement. :slight_smile:

I have been looking around the forum and have found this link for re-imaging the microSD card myself:


using the image from this thread: HOW TO: download/install the Piper SD card image

My son is only 8 years old so this might be a bit over his head, so I’m going to attempt to do it for him. Mainly as a learning experience for me ( lol ). At least I’ll give it a shot and if I fail there is a replacement that will arrive in the mail shortly.

Thanks again for taking the time to help us out!


#4

Unfortunately the microSD card is read-only. I have tried multiple ways to try and unlock it but to no avail. I guess I’ll just wait for the replacement to arrive :slight_smile:


#5

Even though the microSD card was read-only using a standard SD card adapter, I used a Kingston card reader (that connects via USB) and was successful and formatted the microSD card. I am re-imaging it as I type… Fingers crossed…!


#6

And DONE :slight_smile:


#7

Good work, and to think I thought I might need to hold your hand :stuck_out_tongue_closed_eyes: