Pi stays on red light only, will not boot - already tried reimage


The PI would go to just a red light, and not boot up. That started about a month after my daughter started using it, but I was out of town most of the time for work and couldn’t look at it.

This weekend I tried the suggestions on this page: Piper Most Common Fixes

  1. Checked SD mounting.
  2. Used new SD (imaged)
  3. Re-imaged old SD
    (in all cases, waited 5 minutes for the 4 raspberries or some other indication it was doing something)

Neither worked, just a red dot immediately after connecting to power. Also tried disconnecting all controls from the interface pins.
Hopefully the Pi isn’t that easy to short out if this is marketed to children and this is a defective unit. The battery has already been replaced since it was defective and wouldn’t charge (thanks for making the replacement process easy).

Please advise,


PS as a design note, it’s really difficult to get the SD card out with it mounted to the clear acrylic base (I had to use tweezers).


I need to ask, are you sure you pushed the SD card in all the way? If you don’t, it will just sit there with the red light on.

p.s. I agree about the case, but when the Piper team originally designed it, the SD cards had a spring eject which the Raspberry Pi Foundation changed to cut the cost a fraction (every penny counts)


I did. Considering I also reimaged the sd card and imaged a new one, you
could say I checked more than once. Tommy has emailed me regarding this,
hope to get it resolved soon.