Odd issue with app size/screen resolution

Dear Piper Community,

We’ve just had two days of uninterrupted fun with PiperBot. However, something went wrong.
Today we woke up to a completely new reality: our PiperBot is currently buggy. The bug seems to be small, but really ugly, and is pretty
much a showstopper.

The screen resolution (or the resolution at which Piper app is trying to display) got distorted. The biggest problem now is that we can’t see the hint texts, we also can’t see the exit to menu button (when we press middle button). When at main menu, we don’t see the “Update button”.
The app stretched itself so that entire right section is cut off, it also took most of the top space, where the hints used to display.

See the screenshot to see how much of hints we can see now.
Oh, I did the updating to get the most recent version of the app.

Here’s what I tried:

  1. Find “change resolution” option - checked Preferences - to no avail. Was unable to change resolution.
  2. Connected the device to a tv via hdmi - the OS seems to take advantage of more screen, the app was in the top left corner, all visible.
    When I switched back, nothing changed. I read somewhere it might help to change the screen for a moment. Well, it didn’t for me.

So the questions are:

  1. Is this a known bug?
  2. Is there a quick way to solve it?
  3. If there isn’t, where does the game keep the saved state? I think of reimaging the SD card, but I pretty much must keep the save game data. I’m an IT guy with some limited knowledge about Linux machines. If need be, I can attach keyboard to USB and run some mumbo jumbo commands via terminal. Or reimage the card using my Windoze laptop.


If out control station doesn’t get fixed soon, the Cheesteroid will surely smash Earth into oblivion. Help us save your backs, guys!




Hi Lukasz,

Usually this issue resolves itself on reboot (although perhaps you tried this already). Also, did you update to the latest version (2.2.0) as seen in the bottom left corner of the options menu?


  • Jordan
1 Like

Did reboot, way too many times today :slight_smile: Also - did the update to 2.2.0. Did updating till the system was up to date.
What’s more - I’ve noticed we also lost sound. Speaker is loaded, powered on, but there’s only white noise coming out of it. Changing volume on RPi doesn’t do much, the mute checkbox is not selected. To rule out speaker issue - I’ve tested it using my laptop - works just fine.

1 Like

Hi Lukasz,

You’ll can make a copy of the file ~/piper/game/userData/playData/levelsCompleted.txt and then overwrite the same file on a new SD card image to restore story mode level progression. Also, have you tried the potential fix here?


  • Jordan

Will check the “fix all” majick. If it fails, will reimage.
Will report either way.
Piperbot out.


Well, failed with the “self-repair.sh” script. I’m getting a lot of unresolved host names, like archive.raspberrypi.org, updater.playpiper.com, etc - pretty much all hostnames go unresolved. resolv.conf sports just, and still - no domain gets resolved. On a laptop, same wifi network - everything resolves cool.

How do I solve this problem on RPi?


I did remove the entries from resolv.conf with vi (boy it sucks). Then I commented out the four lines that change the file from repair script, since these lines actually broke the script for me.

Running the script now… done. I doubt it helped, since even my terminal window opens in “too wide” mode. Must be something with the RPi soft itself.

Will look for the RPi config script, maybe can change overscan/resolution there.

1 Like

OK, I managed to fix the screen resolution. I first tried raspi-config script, though it’s a drag on a small terminal screen, and then ended up finding this:

Putting these two lines in /boot/config.txt file solved the resolution issue.


One thing that still remains is lack of sound. Any hints here?


Glad I found this thread! One of the games my 8-year-old wanted to play on the Raspbian side of the system (the desktop) required a much larger screen so I plugged it up to our flat-screen which worked great. The issue we found was plugging it back into the Piper screen with the non-standard 848x480 dimensions that was not available in the Preferences > Raspberry Pi Configuration > Set Resolution options. As mentioned above, it requires the config.txt file to be edited.

Trying to edit with the Text Editor did not work for me as the permissions wouldn’t allow saving over the file. I had to use the Command Prompt method. I have experience with both Windows and Linux’s command prompt but my first foray into Raspbian command prompt editing and had to use the Nano editor. (https://www.raspberrypi.org/magpi/edit-text/)

Just in case someone finds this and needs a walkthrough:

  1. make sure to plug in a USB keyboard
  2. exit to desktop
  3. open Command Prompt
  4. type cd / to move up to the root foldeer
  5. type cd boot to open boot folder where the config.txt file resides
  6. type sudo nano config.txt (sudo command gives you permissions to save the file after editing)
  7. edit the config file with the two hdmi_group and hdmi_mode lines above
  8. hit Command+O to save the file
  9. confirm the overwrite
  10. hit Command+X to exit
  11. type exit to leave the command prompt
  12. reboot and the correct screen resolution should be automatically recognized and working

The two lines adds more screen resolution options to the Raspberry Pi Configuration > Set Resolution options so you can now select the Piper screen resolution when changing between TV’s, external computer monitors, and the Piper monitor.

Hope this helps for anyone new that feels lost or intimidated by the command prompt method.


Helpful details. Any thoughts on sound? Oh and this was caused (I think) by a 2.2 upgrade.

1 Like

On my end - while I did resolve the screen resolution issue, it did reappear after a few days. We didn’t attach any other screen to the device meanwhile - so no clue why would it happen again. No luck with sound. I’ll have to reimage the device.

1 Like

One thing to check is right clicking the speaker icon in the taskbar on the desktop (you’ll see it top right after hitting exit to desktop). You should see a dropdown with two options: analog and HDMI. Analog is the setting you want, so click it and see if that helps.

1 Like

Thanks for this thread. That solved the resolution issue indeed. Did anyone get luck in fixing the sound issue ? I have the sound pb only with Pipe game… Other Raspberry pi games have sound… It must be a game level setting, or maybe the game using some kind of codecs broken by the upgrade since everyone says that the sound came off after the upgrade ( that is the case for me also ).

1 Like

Thanks for this fix. We played without trouble until today when the screen just went berserk.

This fixed it!

1 Like

Sound came off for me after the upgrade… on,y the python games have it. However, it sounds with a lot of noise, maybe the codec is the problem.

1 Like

I tried the dev fix script, I think I would rather re-image and copy game progress file. That might do the trick!

1 Like