Not letting us go to other games


#1

My kids are loving their new Pipers, but we’re having some issues.

(1) Every time we turn it on, we have to watch the Piper video. Any way to turn that off?

(2) When we get past the video, the only option is the Piper game. We can go to the main menu. When we push the shutdown button and try to “Exit to Desktop” it just freezes up and we have to turn it on and off.

Thanks for the help.


#2

I have a brand new Piper as well (just arrived in the mail yesterday – 12/24/2018), and I noticed that when I go to the shutdown menu and click “Exit to Desktop,” mine was freezing up as well, but after a few minutes, it eventually exited to the desktop. But it really took several minutes. I was going to power it off, but I thought I’ll just leave it alone for a while just to see if it would eventually either shut down on its own or go to the desktop. It DOES go to desktop, but it really takes a while.

I’m not sure if this is a function of the slow speed of the Raspberry Pi processor, or if it’s some kind of defect. Hopefully, someone from Piper will comment.


#3

(1) You can click the scroll wheel to skip the video - however it won’t really change the boot time to get it all running.

(2) what version are you running - could you go to the main menu, click the gear icon and at the bottom in small letters you will see the version number.


#4

We just started with our new Piper today, and we’re having the exact same problem. When we start up, piper story mode launches automatically. Then when we try to exit back to the desktop, it freezes (or so we thought). Following motowndoc’s message, we waited several minutes, and it does eventually exit to the desktop. Is this normal? We have version 2.4.1.


#5

Thanks Paul for responding so quickly. We have version 2.4.1.

Scrolling does not stop the video.

But the real problem is that we can’t get back to the desktop after the video plays. When I get to the screen that say desktop/reboot/shutdown, the computer freezes.

We got 2 Pipers and only 1 of them has this problem. My son who has the broken computer is about to lose his mind!!! Any help in fixing this is greatly appreciated.

I’m uploading a photo. After the video the story mode / pipercode screen comes up. We can click the top left button, and that’s when it freezes. There is no way to get to the desktop.

Thanks!!!


#6

We gave our 7-year old a Piper for Christmas this year (2018). Assembly was very straightforward and took about 2 hours with help from older sister and a little bit of dad. It had software issues right out of the box and would crash at boot up. Our solution was to reflash the SD card with the latest software update on a separate laptop computer. We are now up and running and everything is functioning as it should. Here are the steps we used to reflash the card:
(1) Remove micro SD card from Piper Rasberry PI. We used tweezers to gently pull it from its slot.
(2) Download the latest version of the Piper SD card image at playpiper.com/pages/software-update#sdcard. There’s an 8GB and 16GB SD card version. They are large ZIP files (3.2GB+) so, depending on your speed, it may take a little longer to download from your home WiFi.
(3) Download and install the balenaEtcher free-and-open source utility for burning files such as .iso, .img and zipped folders to create live SD cards and USB flash drives. It’s simple and easy to use with step-by-step instructions on screen. NOTE: We used an adapter to convert the Piper-provided micro SD card into a SD card since my Laptop only has a SD slot.
(4) After you have reflashed the micro SD card, reinstall it into the Rasberry PI and reboot the Piper.
(5) Connect your Piper to your home WiFi and update your Piper. Hopefully, this helps for anyone having trouble getting up and running.
Happy coding!!


#7

Not scrolling - you need to click the scroll wheel.

I’m sorry your son is frustrated, but he has the chance to do some debugging which is a valuable lesson to learn (Heck I would not be doing this if I hadn’t learned to troubleshoot)

Have him try this:

  1. boot up the pi and let the video run and wait a couple minutes.
  2. Next exit out to the desktop - you’ll probably have to wait a couple minutes for this to happen.
  3. look at the top menu bar where you will see a wifi icon - click on it and shut the wifi off.
  4. reboot the Pi (from the raspberry icon, bottom choice)

Let me know if that works. The engineers have found a bug and are trying to fix it. hopefully it will be a quick fix.


#8

Hi - we have the same issue, long exit time to Desktop - thought is was not possible to Exit to Desktop before reading this - with our new Piper bought for Christmas, version 2.4.1. How will we be notified when you have a solution?


#9

I’ll make sure to post it here.


#10

I’ve got the same question. From the Piper screen, I choose “exit to desktop” and it takes several minutes before the desktop appears.

In the meantime, it seems like the machine is frozen. Is it doing something? Perhaps it needs some kinds of “working” animation to let the user know it’s thinking.

If there’s a way to make the delay something more reasonable, that’d be great!


#11

@tikimojo Steve - exit to the desktop (takes about 3 minutes) then shutoff WiFi as I explained in my post above.


#12

Shut off wifi?

What kind of madness are you talking? :grin:

Here I’ve been doing my best to connect everything to the internet since the 80’s and now you want me to disconnect something that’s an actual computer?

Well, now that I know there’s nothing actually broken I’ll probably just wait the three minutes because getting to the internet is the whole point of going to the desktop.

Perhaps there’s some way someone could put up one of those “loading” animations or something to let the user know the computer is busy doing… something.


#13

I’m just saying that if you disconnect the WiFi then you won’t experience the problem. The next release is close to being released and it will be nnounced here so at that point, you could turn on WiFi again, download the new release and then leave WiFi on.