No wifi connection? WEP 64?


I have this problem with 2 of my SD cards. I’ve followed instructions to set network to ssid, but the ‘apply’ button is disabled, thus not allowing me to change it. Is there another approach I can try?

I also have 1 card that turns blue and then shuts off, as if nothing is loaded on it? How do I resolve this one?



Hi @meemo,

In Network Preferences, can you please try the following:

  1. Configure: interface and choose wlan0 (not eth0)
  2. Check “Automatically configure empty options”
  3. Click “Apply” followed by “Close”
  4. Left click the network symbol near the speaker icon and select your network from the list

Regarding the blue to black screen for the other card, have you visited here? Also, do you see a solid red light and blinking green light when the pi with this card is powered on?



Following your steps for wifi issue, step 3 result: message displays ‘no wireless interfaces found’ and when I hover over network symbol it says ‘wlan0: not associated’


For the card that doesn’t start the os, both green and red lights are solid


Do you have a Pi 2 or a Pi 3 - if you look on the Pi just under the two rows of GPIO pins, you should see it silkscreened on the PCB.

If you have a Pi 2, do you have the wifi dongle plugged into one of the USB ports?
and is it blinking?


I’m using pi2 and the Wifi dongle displays solid light, not blinking.


Ok, does the SD that Tommy sent you boot up and does Piper start up?
If not, can you check the actual size of the card (do you know how to?)


No, nothing starts up on the sd card Tommy sent me: blue screen then a few seconds later, black screen, just like I see when shutting down the pi.

I’ve spent a lot of time trying to get these SD cards working correctly and the software updated… several hours of time for 13 cards + 2 cards that don’t work, searching for solutions on the community. Frankly, I’m quite frustrated and am keeping my fingers crossed nothing goes wrong with the SD cards I have, because my 2 backups don’t work.


if you have 13 cards that boot on the Pi and two that don’t, then those two cards are probably bad. You could try using a utility to do a low level format of them, but that is an issue that is beyond the scope of this forum.

I’d toss them and get two new ones.


Hi @meemo @Paul,

I’m having trouble with both of my pipers wifi connections (I have twins, so each one got one…)

I’m seeing the same thing that Meemo describes - left clicking on the network icon shows “no wireless interfaces found”.

@meemo - was this ever resolved?

I see all the networks available when I boot and click on the wifi icon - so it looks like the wifi is correctly detecting the presence of the networks, however it can’t connect. Also, since it is an old router that still had WEP turned on I updated the config and am using WEP2-PSK now. And the piper screen detected this change and now puts up “PINBALL,WEP” instead of “WEP,unenctrypted” like it was showing before…

So it detects it but cannot seem to connect…

Also - the ip address that I see in “ifconfig” for wlan0 is, which doesn’t look right - I should be seeing 192.168.x.y or something like that, no?

Thanks in advance for any help!


Hi all,

I wanted to report that this is now resolved. The issue (might) have been due to a need for a reboot. I’m not sure but it just started working at a certain point and it was following a reboot that this happened.

The thing which seems to have fixed it for me was right-clicking on the network icon from the desktop and having it do the automatic selection - that series of actions worked for me on my first try on the second machine, so I’m pretty sure that was the crucial step.


Sounds so easy, but this still does not work when plug in the Ethernet . Icon goes from wifi to network, but no update is possible. Tried all the threads on no wifi, but no solutions so far. “Just plug in Ethernet cable” does not work. Anything else?


@cnevers try this, plug in the cat5 cable and open a terminal window, Next type ‘ifconfig eth0’ (that is a zero at the end)
do you see an IP addtess like