No wifi connection? WEP 64?


We received our Piper on Christmas Eve and assembled it Christmas morning.

I tried to connect it to Wifi to update, but it didn’t seem to connect. I could see our network, and enter the password, and click Connect. It goes back to the main screen, but the wifi icon never changes. We rebooted.

We do have WEP 64 802.11b on the network to be backward compatible with some older equipment. I don’t know if that would make a difference or not. (It hasn’t yet).

Any ideas? So far, everything else seems to be working. We are up to the jump button!



For anyone having problems with wifi, try plugging it into ethernet!


Hi @JBurtoft were you able to get the background screen to change when you hooked up the ethernet? Apologies for the wifi not working. We will look into this issue.

Thank you,



The “network” icon went green when I plugged it into the ethernet. I clicked on “update” and it went through an update process, although it looks like it stayed at 1.0.2. I didn’t leave it plugged in for very long, just enough to click “update”.

So far, the game is progressing. No sound, though, but I don’t know what to expect. I’ll open another thread to talk about that.



We had the same issue with the wifi. Plugged the Ethernet cable in and got the update. Once piper was updated, the wifi would connect.


We cannot get the screen to change when we plug the ethernet cable in. What does that mean?


Same here. Son and I had a blast assembling the case and are now up to the black button after using the treasure finding signal! Awesome! We also cannot connect to wifi yet, should we try our home internet cable to hardwire in to the Piper for update, then try wifi?


We can see our network but can’t connect. Is Ethernet the same as hard wiring? Do I need to plug it into the router?


@libsterdc when you say you can see your network, did you enter in your password? You will need to temporarily attach a keyboard to the PI while you enter the passpword for your wireless connection.

Is Ethernet the same as hard wiring? Do I need to plug it into the router?
When you ‘hard wire’ a connection, you use an ‘ethernet’ or ‘cat5’ cable. This allows you to connect the device to your router. If you don’t use a cable, you have to go wireless and that is where the WiFi dongle comes in and the need to choose your network and enter the password for it (hence the temporary need for a keyboard).


We also have no luck connecting to wifi via wireless… It sees our network and we can type in a password but it does not connect. We will try directly connecting to ethernet cable next.


@Paul, Why do you say that you need a keyboard? When you enter your password, there is an onscreen keyboard you can use. Is there something wrong with using the onscreen one?


WifI won't login

@JBurtoft Oh, I didn’t realize there was one! I stuck a keyboard in when I was testing and have the PI connected to a wide monitor, but yup there is a keyboard you can use on the screen.

Learn something new every day. :slightly_smiling:


Plugged in hard line and did the update button, still no WiFi access with my piper, ill start digging around when kids are done playing it. Levels work for now, so WiFi is just a bonus at this point.

NOTE: WiFi shows my network, and allows me to type in the pass word with the on screen keyboard. clicking connect the device does nothing. it wont go past the login screen.


FIXED: (req, USB keyboard)

  1. Plug in a keyboard

  2. boot up to the main screen

  3. place mouse in the middle of the screen

  4. now press ctrl + alt + del , this should open the task manager

  5. move your mouse to the top of the screen, this should show the original Raspberian OS Menu ( original Pi OS that piper is built on)

  6. on the left side you should see a clock and other icons, find the one that says wlan not active

  7. right click and go to network settings

  8. change interface to SSID, then select your network and hit apply (or OK)

  9. wiggle the mouse and you should have to hit ctrl + alt + del again, go back up to the WiFi icon

  10. left click your network from the drop down list, enter your password or SSID key

  11. reboot your Piper and you should now see the green WiFi telling you your now connected, perform an update from the Piper menu now over WiFi, you should be good to go at this point.

  12. Enjoy!


I’m in the same boat WRT wifi - I can see my network and type in my wifi password but never connects. I was able to get internet access when I connected an ethernet cable and an update was begun automatically (nice) but then disconnected the ethernet cable and still no wifi.

Following your steps above I get as far as #3 but doing step 4 does not open the task manager. I’m using a Mac keyboard. Does this matter?


We had the same problem as that, but then miraculously, while our internet went down because of a power issue, the Piper connected to the internet once the internet came back on. I know this seems silly, but maybe something might happen if you shut off your internet and turn it back on. Also, try unplugging the wifi chip, and plugging it back in. Hope it helps!



No idea on the Mac keyboard part… I just don’t have one to test with, sorry. The goal of these steps is to get to the raspberryian OS, this way you can manually enter your wifi info with out using the Piper program (which is really an overlay OS or fancy GUI) … does Mac have its own version of ctrl+alt+del that gets you to the desktop? What ever that might be should work on that keyboard… ill try to look it up quick.

ok try - option+command+esc … let me know if that works on that keyboard as most Linux OS’s probably auto detect your hardware.


The keyboard shouldn’t matter. I use a mack and have both a mac keyboard and a generic Logitech board and they both work with the pi.


You say “shouldn’t matter”… If you have a Mac keyboard could you test the theory and perform a Ctrl+Alt+Del? Then give accurate tested results, as I do not own one myself to test with. TY


I just used a mac keyboard and ctrl-alt-delete works the way it would on a generic keyboard