No sound, speaker icon greyed out


The RPI has no sound and the speaker icon is greyed out. When I go to Preferences-Audio Devices it says "No ALSA audio devices were detected. Enable the internal audio device, or connect a USB or HAT audio device.

When I go to sudo raspi-config and try to select 3.5 audio output, I get the message “There was an error running option A4 Audio”.

Please help!

  1. are you using the speaker?
  2. is the speaker charged up?
  3. have you tried plugging in a set of headphones?
  4. how long have you had teh Piper?
  5. did sound ever work?

  1. I’m using speaker and headphones, switching and trying both.
  2. Speaker is charged.
  3. yes
  4. Problem started today. Haven’t used it in a while.
    5.Yes, sound worked last time I used it–about a month ago.

It seems like a configuration problem that might be fixed through terminal, but I don’t know how to do that. The speaker is literally greyed out and when i right click on it, it says “No audio devices found”


sorry it took so long to get back to you, we were invaded by grandkids and they have just left.

What version of Piper are you running?
Have you updated the pi?

sudo apt-get update && sudo apt-get upgrade -y

Go to the Menu->Preferences->Audio Device Settings and see if you see this:

Press the ‘Select Controls’ and you should see this:

I then check off the PCM box and hit 'Close:

You should now see the volume control:

Try adjusting this and see if you have sound


No problem, thanks for your help! I’m running the most recent version of Piper 2.02 and yes, I updated the pi using those commands. I’m wondering if something bad happened when I ran the updates. The speaker worked prior to the updates.

I do not see that option when I go to Audio Device Settings. I get a message that says "No ALSA audio devices were detected. Enable the internal audio device, or connect a USB or HAT audio device.” The speaker icon on the desktop is greyed out, too.


Please type the following and report what it shows

cat /etc/os-release


Sorry for the delay. It’s been a busy week. I’m a teacher and we just came back this week. Just noticed your message. This is what I got when I ran the command:
pi@raspberrypi ~ $ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 8 (jessie)"
NAME="Raspbian GNU/Linux"
VERSION="8 (jessie)"


Seeing that you are a teacher there is no need to apologize.

I’m going to reimage an SD card with the 106 version and run the update. I’ve been building the 202 as a brand new a image and that may be why I don’t lose sound. I’ll try to get this test done tonight since I’m babysitting my 6 mth old granddaughter tomorrow


Ok, so I still show sound after nstalling v106 and upgrading to v202 but I want you to check a couple things. I’m wondering if your SD card is too small, so please exit Piper and open a terminal window.

  1. type df -h which will show the space on the SD card. You will see something like
    Filesystem Size Used Avail Use% Mounted on
    /dev/root 7.2G 5.9G 965M 87% /
    devtmpfs 427M 0 427M 0% /dev
    tmpfs 432M 0 432M 0% /dev/shm
    tmpfs 432M 6.0M 426M 2% /run
    tmpfs 5.0M 4.0K 5.0M 1% /run/lock
    tmpfs 432M 0 432M 0% /sys/fs/cgroup
    /dev/mmcblk0p1 56M 20M 36M 36% /boot
    tmpfs 87M 0 87M 0% /run/user/1000

The /dev/root line is what I want to see
2) type sudo dpkg -l | grep alsa-utils this will show if it is installed and should look like this
pi@raspberrypi ~ $ sudo dpkg -l | grep alsa-utils
ii alsa-utils 1.0.28-1 armhf Utilities for configuring and using ALSA


i have the same problem and when i typed
omxplayer -o both example.wav
i was able to hear the voice in speakers(left and right spekers as left and right channel resp).
plz help as soon as possible i tried all explaination above but none worked.thanks for the help


Hi @amishm766,

Was the sound working and all of a sudden it stopped? Also, did you try Paul’s suggestion above and run “sudo apt-get update && sudo apt-get upgrade -y” in a terminal window?


  • Jordan


I never found a solution. I ended up doing a fresh install of the program. I was so frustrated but nothing else would work.


hi again my speaker won’t work either
please help



Hi @roarac,

Was the sound ever working for you? I’m assuming you 1) charged the speaker and 2) used the on/off switch (with low/high volume) on the side.


  • Jordan




what to do now