No sound output from Raspberry Pi after updating


#1

Right, so I recently upgraded my Raspberry Pi to Raspbian Stretch, and a few months later (now), my sound completely stops working. When I try to open the sound options menu, it give me this error message:
“No ALSA devices were detected. Enable the internal audio device, or connect a USB or HAT audio device.”. I’ve tried everything at this point, except for redownloading the software.


#2
  1. How recently did you upgrade to stretch?
  2. what did you do to do the upgade?
  3. Was sound working after the upgrade? If so, what else changed?
  4. how much free space do you have on the SD card? (in a terminal window type df -h and it will tell you)

#3
  1. A couple of months ago
  2. I took out the Micro SD card, put it in my Mac, downloaded Stretch, and flashed stretch onto the MSD.
  3. Yes, sound was working after the upgrade.
  4. For that one, I got this:
    Filesystem Size Used Avail Use% Mounted on
    /dev/root 7.2G 5.4G 1.5G 79% /
    devtmpfs 460M 0 460M 0% /dev
    tmpfs 464M 18M 447M 4% /dev/shm
    tmpfs 464M 12M 452M 3% /run
    tmpfs 5.0M 0 5.0M 0% /run/lock
    tmpfs 464M 0 464M 0% /sys/fs/cgroup
    /dev/mmcblk0p1 44M 23M 22M 51% /boot
    tmpfs 93M 0 93M 0% /run/user/1000

#4

Also, I discovered that I cannot save a file after making changes, which I discovered after going to /boot/config.txt to change a setting manually. After opening a terminal window, entering sudo nano, and changing, saving, and rebooting, I had checked on it, only to find that the entire file was blank! I think something is definitely wrong here…


#5

Ok, to be clear, this is not happening on a Piper SD card. You have a SD card flashed with a version of Raspbian from the Raspberrypi Foundation…correct?

How do you shut off the system? Do you just shut off the battery or use the shutdown command?

If you are just powering off the battery is is quite possible that you have corrupted the SD card. And if things ‘were’ working and now don’t, that is my guess as to the cause.

I would reflash the SD card and be more carefull shutting down the Pi. - note: after using the shutdown command wait at least 30 second before shutting off the power.