No sound in YouTube


If I try to watch a YouTube video, There is no sound. I can turn on subtitles, but sometimes the sound matters in videos. If you have an answer, reply!


do you exit out of Piper and start the browser and then go to YouTube?


Yes, and I have the speaker charged and plugged in too.


Do you hear sound when you connect headphones? Trying to decide whether this is speaker related or software related. I assume the speaker is working normally in the game?



The speaker normally works in the game, but not when I do other things on my piper.
But it worked! Thx so much!:grinning:


HI @CoolDawg,

I was just wondering if you had any details on how you fixed your audio issue. I am experiencing the same issue. Audio plays fine while in the Piper game, but if I play a YouTube video, I hear no sound. I am using the speaker that came with the Piper.

I did notice that the speaker icon in the top right of toolbar is greyed out and has ax x through it. If I click on it the volume slider is greyed out as well. I went Preferences > Audio Device Settings and when I click on that I get a message saying No ASLA Devices Found.

For those following my other threads, we also had this issue before we re-imaged our Piper, just never got around to posting about it. But since we’ve been getting everything else sorted out, thought I would take a crack at this audio issue.

Any help or advice would be greatly appreciated.



Are you using the speaker from Piper and is is charged up? I just attached a speaker and it is working fine for me.

Go to the Pi menu (top left on screen) -> Preferences->Audio Device Swttings it will probably come up empty so click the ‘Select Controls’ button and ckect the ‘PCM’ box and close that popup window. Make sure the PCM slider is way up and see if you get sound from YouTube.


Hi Paul,

I am using the speaker from Piper and it is charged up. We can hear sound fine while in the Piper game, we just can’t hear any sound outside of the game.

When I go into Preferences > Audio Device Settings I get a message saying No ASLA Devices Found and I don’t have any options do anything in there.

Any ideas?



Hi, I just flashed an SD card with Piper v2.0.2 and stuck it in the Pi. After booting I exited Piper to the desktop and went to the Menu->Preferences->Audio Device Settings and see this:

I Press the ‘Select Controls’ and I see this:

I then check off the PCM box and hit 'Close:

And now I see the volume control:

Are you not seeing this?


Hi Paul,

That’s correct we do not see any of that. When we go to Audio Preference Settings we just get a message saying “No ALSA audio devices were detected. Enable the internal audio device, or connect a USB or HAT audio device”. We then only have the option to click ok on that message window and then it closes. So, the audio preferences window never opens for because we can’t get past this message.



did you flash your SD card directly from the v2.0.2 image or did you upgrade from another version?


I used the v2.0.2 image.



I sent you a private message.


Are you running on a pi model 2 or a pi model 3?


3 I believe. I didn’t initially know but it looks like from what I’ve read that wifi and bluetooth were not built into the 2 model and mine has both of those so I believe it is a 3.



Well, i’m at a loss. If you followed th esame steps I took, then we should be seeing the same results. I hoped the Pi’s we were using were different and that might explain it, but since they are the same I must have done an extra step that I didn’t note or explain. sigh…


is there like a command that i can type into terminal to get volume in web browser?


read the prior post (in this thread) I made with the images and see if that will work for you


OK, i tried what you said multiple times and it still doesn’t work. Any suggestions?


Are you using a Pi model 3?

I’m going to walk thru the reflashing of an SD card again tonight and see what happens. It is possible I did something that I don’t remember (or wrote down) I’ll post an update tomorrow.