Menu Missing and Update Error


When running the command to show status of update “cd piper && sudo python” the “Oops! an error occoured” msg refreshes and comes to the front of the screen. Then there’s about six screens of code that roll by with a different error msg. I’m including the first and last page of the msg in hopes that y’all will have an idea of what further steps to take.


By the look of the picture, it looks like you are not connected to the internet. Try connecting to wifi. If you don’t have wifi, try connecting via ethernet.


In a terminal type:
sudo pip install pydub


Hi Greg,

Thanks for the suggestion but that doesn’t seem to do a thing. =/
I don’t have connectivity issues either. Wifi connection is fine.


@Justin1 -

  1. what size is your SD card?
  2. in a terminal window type: df -h
  3. what is the Avail column for the first line read?
  4. If you have a 16GB card, have you tried reflashing the SD card?



I just tried to run Piper again and while it gave me the usual ‘Oops, the update’s not finished, give it 10 mins’ right after a terminal popped up and it actually looked like it was checking on things and downloading things, then it disappeared without seeming to solve anything. Isn’t there a command I can enter that will show me what it’s currently working on, like downloads and what not?


I would reflash the SD card - use the v2.0.2 version so it will fit on your SD card, then do the updates.


Has anyone figured this out? i have the same issue and nothing works. This piper is now useless.


See my response in the thread you opened