Jump button does not work


We have gone through installation of jump button several times and can not get the jump button working. The button itself might be defected. Is it possible to replace it. We bought our piper only couple of month ago.


Hi @LeoMaeda,

The best way to test whether you have a defective button is to first make sure that when you touch the wires together, Piperbot is jumping. That means the correct pins are being used and the software/hardware are interacting properly. Then, if the button is not functioning properly and you are not able to bend the prongs into a position that establishes the connection, you can switch to one of the spare black or gray buttons. If those are able to work then you can just switch the top with the yellow button and you will be set to go!



Hi. I am having the same problem. However, jump is not working even with wires touching. I’ve tried other wires too.

Any advice?

We can’t progress until this step is completed.




Hi @Matthew,

Can you please post a picture of your jump wires plugged into the Raspberry-Pi?


  • Jordan


Our jump button doesn’t work either. We have tried touching the wires together but still no luck. Can somebody please help my 8 yo?


Hi @Nicholas123,

Can you please post a picture of how you have the wires plugged into the Raspberry-Pi? From left-to-right in the front row of the Pi, the pins should be:

GG…RR…BB…YY, where two wires/pins per button and G = green button, R=Red button, B = blue button and Y = Yellow (or jump) button


  • Jordan


Hi Jordan. I think we have fixed it. I found a photo of what the Raspberries Pi should look like. Didn’t realise Nicholas has moved the yellow wires :grimacing:. Thanks for the prompt reply.


Great to hear!!


  • Jordan


Our jump button is not working either 🤷 even when we touch the wires together. Can you help?


Have you doubbled checked you have tem plugged into the correct GPIO pins? They should be plugged into the 5th and 6th pins counting from the left of the GPIO pins