Issues after downloading/burning new v202 image


Hi Support Team. After downloading and burning a new image of the v202 release, we’ve having some issues.

Here’s what happened:

  1. Original SD card damaged/unreadable after trying to extract it from the Raspberry Pi (difficult to remove due to fouling on the perspex of the Pi mounting bracket). I was originally trying to remove it to image it and copy the image to a 16GB card instead of the 8GB card, which had only 250MB free.

  2. Downloaded the v202 image from Dropbox, burned it to a 16GB card and expanded the filesystem.

  3. Set it up for my local network

  4. Ran apt-get update, followed by apt-get upgrade, to get the latest updates/security patches.

  5. Loaded it up.

  6. Can’t exit to desktop - Pipercraft automatically restarts every time after clicking “exit to desktop”.

  7. Instructions/subtitles not displaying correctly - only the top half (or so) of the letters are displayed in a narrow strip across the top of the screen. Also the speech appears corrupted, does not play correctly (although the music is OK when Pipercraft starts up).

I’m thinking about going back to the version 1 image and upgrading from there. Everything worked perfectly before we had to start again with the new image.

Thanks in advance.


did Piper run when you first ran it before doing the api-get’s?


hi @vk5ztv,

I would try rolling back your update and then re-pulling. Let us know if the problem persists after trying that.



I had difficulty with piper not working - was not loading.
I followed some instructions that were in the forums - which fixed the original error, but created new errors
So … I then emailed a screen shot, got some advice, that did not work.

I have now downloaded the new ?? 202 image and it won’t fit on the original SD card.
At the moment I am installing raspbian onto it in the hope of getting the pi working again.
how do I re-install piper? is there a package or other that I can use?
At the moment I have a keen daughter (who may have created the initial problem - the battery packs are too easy to turn off)

Any help or advice would be appreciate.
That you.


Just a follow up - does the SD card that is available in the store contain the latest Piper? I think I have killed the current one.


Ok - so it was the SD card - bought a new one and put the new image onto it and all good now.


Hi @Tommy - I started again. Reflashed the v202 image (thankfully, I’d already mounted the image on my desktop and pre-configured wireless, apt-cache proxy settings etc to suit my local network), booted it up, expanded the filesystem to fit the card (I’m using a 16GB card) and started up Pipercraft. All worked fine. Tried update through Piper, reported “Your system is already up to date”.

Exited Pipercraft (which now exited cleanly and did not restart), did apt-get update/apt-get upgrade, retested everything and it’s all now working perfectly. :slight_smile:


Just one more minor issue regarding excessive over-scanning at the bottom of the screen, but I’ll search the forums and open a new issue for that if I can’t solve it.


@vk5ztv great job hacking! Let us know if anything else comes up!