Issue updating an SD card


#1

I ran into a few update issues this week. I was trying to update story levels on a kit by clicking on “Download new level” from the story level selection area. On a couple of my Piper kits (I have about 6 I’m managing for a class), doing this would update with the latest version. On a couple of them I got the new story levels, then had to go to the update button on the home page for the version update. But on one kit, each time I clicked on the “Download new level” button, I would continue to see the wireless connection page. I swapped the wireless dongle out with one I knew worked and this didn’t help. When I swapped out the SD card, the new card updated fine.

Is there a possibility my SD card is corrupt? Besides not updating I haven’t had any issues with it. Would a total re-install fix this issue?

Also, why was the update process so variable across the different kits?

Thanks for any ideas!


#2

Hi @carrisima,

Try a fresh pull on the nonfunctioning SD card by following these instructions.

Tommy


#3

I followed these instructions and saw a bunch of errors. :disappointed_relieved: See attached.


#4

Any ideas on what could be wrong? Should I reimage the card?


Piper Most Common Fixes
#5

Hi @carrisima,

Assuming you were on version 1.06 or higher, please try the following in a new terminal window:

  1. “cd piper” [enter/return]
  2. “sudo git reset --hard c1cbf05 && git clean -f” [enter/return]

Finally. launch the game and hit the “update” button. Please be patient as the update may take several minutes.

Thanks,

  • Jordan

#6

Thanks Jordan. Neither of the cards I’m having issues with are on 1.0.6. Can I still try the git clean command on them? Here’s a summary of the cards and the issues I’m having. It’s really odd, I’m trying these cards in the same Raspberry Pi and getting really different results.

  1. Version 1.0.4
  • Has updated levels to Rainbow Bridge, Funky Fungi, and Return to the Cheeseteroid
  • Will allow Pi to connect to my home wireless network
  • Attempts to update but returns with message that my system is up to date
  1. Version 1.0.5
    *Will not allow Pi to connect to the wireless network
    *Does not have any updated levels

I downloaded the 1.0.6 full image and tried to use Etcher to update one of these cards (I think it was the 1.0.5 card) and Etcher returned the message that there wasn’t enough room on the drive.

Thanks for any suggestions you have to get these updated! I have another 5 kits to update so would love to be really proficient in dealing with these problems.


#7

Hi @carrisima,

Since neither of the cards are on v1.0.6, please try the following instead:

  1. “cd piper” [enter/return]
  2. “sudo git reset --hard b0b4e81 && git clean -f” [enter/return]

And then launch the game and hit the “update” button.

Thanks,

  • Jordan

#8

And now I have a third SD card giving me issues. This one boots directly to the desktop. When I click on the Piper shortcut to launch, it either spins the cursor and nothing happens, or the title video plays and then I am back to the desktop. I tried the git clean command from your previous post then tried to pull a fresh copy of Piper. I see these errors:


#9

I found an earlier post about this problem with card #3 and was able to fix it. Now I have a new problem, but I’ll start a separate post.


#10

I tried this with the card on version 1.0.4. After running this command I see the message "HEAD is now at b0b4e81 Merge branch ‘staging’ "

I launched Piper and attempted the update, still get the message “Your system is already up to date”

I then swapped in the card with 1.0.5, and ran the command with the same results. I opened Piper but still can’t connect to the wireless. This is the same Pi that I used with the other card, so it’s not an issue with the hardware.


#11

Hi Jordan-

I wanted to check in and see if you have any thoughts about this. I went through all the problematic SD cards in my collection (about 7), and have at least two in both of the categories described above plus some other random issues. I am using the same Piper kit to update all these cards, and most of them updated without any issues.

  1. Version 1.0.4 that thinks it’s updated. I ran the commands you gave me above and this doesn’t allow these SD cards to recognize the new update.
  2. SD cards that won’t connect to wifi. Just won’t make the connection. One is 1.0.3 and one is 1.0.5
  3. Piper opening video plays but then kicks out to the desktop
  4. A couple that simply won’t boot, most likely corrupted.

I don’t want to pitch these cards unless you think it’s a lost cause. In which case, can I swap these out with you for some new working cards, or should I just go out and buy some new SD cards and mount the v1.0.6 image available on the site?

Thanks for all your help!

-Carrie


#12

It sounds like we are in a similar situation. It says the OS is updated, but getting stuck on Mars level with a spinning cursor.
I tried the Terminal commands and other instructions on this thread to no avail.
My sons were really enjoying the first level! Let’s keep troubleshooting until we can get them back in please.
Thanks Jordan,
Greg’s dad, James


#13

Hi,

Please try the potential solution here: Piper stuck loading level

Thanks,

  • Jordan

#14

That worked, thank you!