Issue after an update


#1

Hi there,

My daughter is continuing using her computer, and now is using it with scratch on top of keeping building world’s in Piper.

After a upgrade ( a simple apt-get update upgrade with no change at all in the config), the OS seems not recognizing the keyboard, nor the mouse, nor even the Bluetooth or wifi connection.
We are still under stretch, but it is as if the upgrade failed somehow (there is a “failed to start load kernel modules” at the startup that is worrying me…). Is there a way to fix it or to reset ?

Best regards
Thibault


#2
  1. Did the update/upgrade finish without errors?
  2. how does your daughter shut off the pi?
  3. Can you open teminal window and type ifconfig please show the results
  4. do you haave a cat5 cable you can use to plug the pi into your router?

#3
  1. I can’t say, I don’t know…
  2. Usually she shuts it down using the GUI (she does not unplug the battery )
  3. Nope, the USB doesn’t seem to be loaded, this no keyboard detected
  4. I tried: the pi is correctly connected, but no remote connection seems to be allowed (I tried ssh)

#4

I investigated a little: actually, she said that the Pi froze while she was trying to use scratch 3.0 in Firefox (and during the upgrade). Thus it shut down incorrectly when the battery ran off.

I guess I will have to get my other SD card back and flash it with a fresh 2.4.4.


#5

==> better and safer: I still have an older version of Piper on another SD Card: I will try to launch the official upgrade tonight. I will then try to retrieve all her scratch projects from the frozen SD Card with my other computer.

Lesson learned: BACKUP the projects on the familyNAS before trying to do anything dumb :smiley: