HOW TO: download/install the Piper SD card image


#1

Here is the direct download link to the SD card image and you can install the Piper software yourself if you have a card reader.

1. Piper image file: see below for new location

2. After downloading the image file, use Etcher to burn it to your SD card.

Other instructions for installing:
Windows: https://www.raspberrypi.org/documentation/installation/installing-images/windows.md2
Mac: https://www.raspberrypi.org/documentation/installation/installing-images/mac.md

(I copied this to a new topic becuse I kept having a hard time finding it.)

UPDATE 02/29/2016 !! - If your Piper boots to desktop, but doesn’t load the game, please try the following fix here: Piper Boots into desktop


Blue to black screen
Piper Boots into desktop
Can not find game
Help with new Piper
Raspberry Pi board frozen in middle of game
Piper boots to a flashing cursor
Open Source software/blueprints
Piper Boots into desktop
How do you get into story mode?
Two R. Pi display colors screen from various SD, with 1.0.2 IMG
Fsck what is it doing?
Can't get past intro after loosing power during update
Piper isn't booting up
Piper v1.2 / Pi3 won't power on
My piper won't boot
Piper Boots into desktop
Tryed to connect to bluetooth - kernal.img corrupted
Level 4 starts blacked out with part of the wrench visible
Lines of code just keep running when powering on
Level is not loading
Won't finish booting on
Piper not booting properly
Piper not getting past booting up
Vanishing piper program
Stuck on Command Prompt
Startup stops, internal hardeware clock error
#2

Is there a mirror anywhere?

Dropbox produces Error 429 (This account’s links are generating too much traffic and have been temporarily disabled!)

Perhaps providing an official checksum and a torrent (!?) or other link (S3 bucket?) may help deliver the massive download more efficiently.


#3

Hi,

It’s been over 9 hours now and the Dropbox link still doesn’t work.

Can you please let me know how I can download the image as we are unable to use our Piper - boots directly to desktop.


Piper Software Update! Version 1.0.6
Piper won't boot
Updating a LONG time
Piper Boots into desktop
Piper stuck after update
Network not working, neither Wifi nor Ethenet
Piper 1.0.2 won't update - never makes progress
Screen rainbow and piper does not work
#4

LATEST VERSION (ver2.1.0, 10/01/2017):

Note: please check what size microSD card you have before downloading. You’ll find the number/size on the card. Our newest kits ship with 16GB cards. Older kits ship with 8GB cards (if your card is black and says “Piper” on it then it is an 8GB card).

**** 16GB SD CARDS ONLY !!! ****

16GB - Piper ver2.1.0 FULL image (14.84GB) found [here]

16GB - Piper ver2.1.0 COMPRESSED (ZIP) image (3.16GB) found [here]

16GB - Piper ver2.1.0 COMPRESSED (GZ) image (3.16GB) found [here]

==============================================

**** 8GB SD CARDS ONLY !!! ****

8GB - Piper ver2.1.0 COMPRESSED (GZ) image (3.28GB) found here.

OLDER VERSIONS:

8GB - Piper ver2.0.2 image (7.40GB) found here.

8GB - Piper ver1.0.6 FULL image (7.40GB) found here.

8GB - Piper ver1.0.6 COMPRESSED (3.37GB) found here.

Thanks!


Piper Software Update! Version 2.0
Brand new piper powers on but won't boot
Piper 1.0.2 won't update - never makes progress
Google Chrome on PiperBot
Update Error Message
Most Common Christmas Fixes
WifI won't login
Not booting to Piper and now it’s asking for a Password?
Can't get to story mode
#5

I’m not sure Google Drive is a workable method to distribute files of several Gigabytes to a large number of users. Either that, or something is wrong on my side, because I can’t download either of these files. What about Bittorrent?

Or maybe there would be a way to distribute an installer of just the program? Let maybe those with working SD cards who just need some bugfixes do an apt-get update and provide an installer for your additional software that comes on top of the OS - that should be much smaller.

EDIT: So downloading failed right away. If I re-try download in Firefox, it downloads one or two MB before failing again. The file grows in size each time, but I was not feeling like klicking “re-try” a few thousand times…
BUT, on Linux I copied the direct download link with a right-klick on the item in the download progress list of Firefox (no clue how this is called in English), and selecting “copy download link” or something like that. In a terminal, I used
"wget https://doc-10-20-docs.googleusercontent.com/docs/securesc/…" (paste loooong download linke here)
For now it is happily downloading (500MB and counting). Fingers crossed!

EDIT2: For anyone having the same issues and trying this, you may want to use
"wget -O Piper_ver1.0.2.zip https://…"
as this will avoid creating the output with a barbarian file name composed of random symbols. Hope this would work, I haven’t tried it myself as my initial download is still in progress.

EDIT3: I can confirm this last comment to be working fine for downloading the image file.


Network connection
#6

I have downloaded both the image and the .zip image. Neither work on mac - the zip crashes on decompress and the image can’t mount. The SD card is fine and I can see all the files on it etc, but it goes straight to the desktop.

I have tried the raspberry pi instructions for putting the image on the card and I’m not a programmer and so when it tells you to enter the path for a mac file I have no idea how to do that.

I have to say this is ridiculous. This support site has links that don’t go anywhere, instructions you can’t follow. The kit came with one pack of the screws missing so we had to go to the hardware store twice to find ones that would work. Then this stupid SD card drama - we have bought an SD card reader, and spent hours downloading these files only to find they don’t work.

It didn’t arrive before Christmas and so this thing has now caused so many rounds of tears that it’s been an insane waste of money.

My son is fast thinking electronics suck because of this.

Please send me a new kit and one that works or send my money back.


#7

@Piper Could we have the md5sums or some sha???sum or similar please to check the files we download are fine?

EDIT: I compared the md5sum of the downloaded raw image with the one from the image I extracted from the .zip file. Both match, which to me means that there was most likely no corruption in the transfer. This is the value I get, in case it is of use to anyone:

[janw@mypc piper]$ md5sum Piper_ver1.0.2.img
05509350d9916bb33254758d41732191 Piper_ver1.0.2.img

EDIT2: Got round to flashing the image onto the SD card (1,7 MB/s, 80 minutes of transfer, never seen an SD card that slow - or my al cheapo USB/micro SD adapter is crap). Anyway - it works!!!
@jameshurman Not being able to mount the downloaded image is normal. This contains an entire partition table with two file systems, so unless you specify the exact offset to one of the file systems inside the image, this cannot be mounted. But once copied onto an SD card, the Raspberry Pi should be able to boot from it and Piper should work. Sorry I don’t have a MAC and can’t help with copying the image onto the card.


#8

I get an error unzipping the smaller image in OSX. In terminal I get:

Pauls-mini:Downloads Paul$ unzip Piper_ver1.0.2.zip
Archive:  Piper_ver1.0.2.zip
warning [Piper_ver1.0.2.zip]:  76 extra bytes at beginning or within zipfile
  (attempting to process anyway)
error [Piper_ver1.0.2.zip]:  reported length of central directory is
  -76 bytes too long (Atari STZip zipfile?  J.H.Holm ZIPSPLIT 1.1
  zipfile?).  Compensating...
   skipping: Piper_ver1.0.2.img      need PK compat. v4.5 (can do v2.1)

note:  didn't find end-of-central-dir signature at end of central dir.
  (please check that you have transferred or created the zipfile in the
  appropriate BINARY mode and that you have compiled UnZip properly)

and it won’t unzip.


#9

That seems to be an OSX-specific issue. I had no problems unzipping in Linux (Fedora 23).


#10

When trying to burn the image using Etch I got this error

SDHC Card - 7.9 GB
D:
TOO SMALL FOR IMAGE

Do you I need to format the drive first? Or etch should take care of it?

Thank you.


#11

You need a bigger SD card. Not all 8GB SD cards are the same size. At one point I bought 8 SD cards - from the same manufacturer - at the same time - and ended up with cards of 4 different sizes slightly above and slightly below an actual 8GB


#12

I recently bought it and not willing to spend more money on it :frowning: can I
just not reset it?


#13

No you can’t reset the size of the card. It’s like trying to put a size 12 foot into a size 8 shoe.it just won’t fit


#14

Hi Paul,

I know card size cannot be reset, but somehow existing image was copied over to existing 8 GB piper, can I simply not get existing copy to burn?

@jordan the standard SD card that comes with piper is 8GB how come 7.1GB piper image be copier over to it?


#15

Not all 8GB SD cards are actually 8GB - I bougth 8 Sandisk SD cards at the same time from the same company. Here is what I got
A - 7.91 GB (7,906,263,040 Bytes)
B - 7.95 GB (7,948,206,080 Bytes)
C - 7.95 GB (7,948,206,080 Bytes)
D - 8.03 GB (8,026,849,280 Bytes)
E - 7.95 GB (7,948,206,080 Bytes)
F - 7.91 GB (7,906,263,040 Bytes)
G - 8.03 GB (8,026,849,280 Bytes)
H - 7.95 GB (7,948,206,080 Bytes)

as you can see, only 1 is actually greater than 8GB. Part of this is due to some of the flash memory that is unusable.

Piper is extra code (mostly written in the Python languare) that has been added to the standard raspian operating system. Now if the piper team could create an image where they removed unused space, the file could be a lot smaller (2gb) and then ou could tell the PI to expand the system to fill the card. But that is currently not the case.

The 1.0.2 image is 7.95GB so looking at my SD cards, it won’t fit on 1/4 of my SD cards.


#16

I had the same “TOO SMALL FOR IMAGE” problem with Etcher and tried a couple of things to make it work but couldn’t. In the end I had to use the Pi.org’s instructions provided by Paul. https://www.raspberrypi.org/documentation/installation/installing-images/mac.md

I’ve never used the mac terminal before. It wasn’t hard other than the lack of progress indication once the writing process executed. The terminal will only show a box under the executed line for however long the writing process takes (I wasn’t sure it was working but showed faith by letting it sit for half an hour). This process still reported an error (shown below) but Piper appears to be working solid now.

dd: /dev/rdisk3: Input/output error
7581+0 records in
7580+0 records out
7948206080 bytes transferred in 576.083681 secs (13796964 bytes/sec)

If anybody’s familiar with this kind of error, can you say if it will be a problem?


#17

It could be a problem. If you look, it read 7581 blocks of information but wrote 1 block less (7580) so it all depends what was in that block.

I wouldn’t trust it.


#18

The default SD card that comes with Piper is 8GB only, whereas the image that is available for download is more than 7GB. Therefore, I had to purchase a new 16GB to burn it. I would suggest Piper should include 16GB SD card to allow people re-burn image when required.


#19

You should be able to mount, extract and collapse the image with standard linux tools, I think they’re even compatible with Raspbian. There’s also windows tools, just mount the image on your PC and cut another image yourself with the free space removed. I ALWAYS get around double the size these days for just such a reason, but recently I’ve been buying 64 GB cards in bulk. I usually use BerryBoot with a bunch of different images, I havent used it for piper yet but I plan to in the future.


#20

Hi Paul, i had a problem with my installation and needed to download a new image. i reformatted the sd card that came with my piper (dec 2016), however it is not big enough to hold the 1.06 image. This is the sd card you guys recently supplied to me. Should i be downloading the image for an earlier version that may be smaller?

the 1.06 image is 7,948206080 and the sd card that came with pipe is only 7.4gb.

please advise.