Help With Power Plant Level!

We have been trying to figure out how to build the button but nothing seems to be working. The wires are connected correctly, but the button will not work. Is it the big black button with the 4 prongs? Or the smaller buttons with 2 prongs? The picture is a little unclear of where to place these buttons and we want to move on to the next level!! Thank you!

1 Like

its teh button with the 2 prongs. make sure the wires are aligned to both edges of the button. thats the only way the current can flow

1 Like

We are having the same problem. We have tried with several different 2 prong buttons and moved the wires in multiple configurations, but can’t seem to make a connection.

1 Like

@JasonsMom are you still having problems? Could you take a picture of what you have tried please?


Please see my post “Button, switch and breadboard tips” It’s a bit long winded but may help with getting the switches working.


We managed to get past it by just holding the wires to the switch and not using the breadboard. The button did work correctly in the breadboard the next time it was used in a level. Not sure if he had it set up wrong originally, but he had tried it in a bunch of different configurations to no avail.

Thanks, we will have a look

We are stuck at the point where you need to charge the battery to open the door. We opened the valve, the water began to flow, the game said the battery was charging and had reached 25%, but then nothing more happened. We closed the valve and the battery’s “charging” graphic continued to flash. Is it stuck there, or did we miss something? We’ll try playing the level up to that point again.


Figured it out! We missed the part about pushing the button.


Nissua, We can not find the correct button that we’re supposed to put in at the beginning of the power plant level? Do you happen to know which button we’re supposed to use. It flashed on the screen too quickly for us to tell which button to use on the small breadboard. Is it a button with a round top, that says to wash before using, which doesn’t make sense to me at all, I thought electronic components shouldn’t get wet. Or is it one of the other buttons that we should use. I am sorry if this doesn’t make sense, I barely grasp what is really going on, and my eleven year old daughter totally stops when there is a problem we can’t figure out. Any help will be appreciated. Also, did you have trouble with getting your controller buttons to stay in? Ours keep wanting to fall out and don’t really work that well at all, they keep falling out.



Can anyone give us a hint as to which electronic component to use in the power plant level? I tried taking a screenshot of the place in the level where we are having difficulty. It shows three grey-colored square spaces or squares, with white squares around the three grey squares. I know I am not explaining this well, but it is how they appear to me. My daughter is having great fun playing in the Hogwarts Minecraft world in sandbox mode, but I would still like to eventually figure this problem out. Now that New Years and the holidays are over, I am hoping to get some response since it is frustrating trying to figure this out without some advice. Also, can someone give the steps of how to replay or repeat the last learning objective that you are trying to complete. My daughter and I have just had to turn off the piper power source and start over, but I know there must be an easier way. Also, how to return to the main menu screen without turning it off would be helpful. thanks for any help!


@Pavlyukovskyy, so my daughter placed the red and blue wires between the green and red button wires on the Raspberry Pi, then she placed the other ends of the red and blue wires in the top 3rd and 6th places in the top left on the small breadboard. I don’t know if this is correct or not. Then she is unsure which electrical component to place in the blinking spot that shows three grey-colored squares or spaces with white squares around they grey-colored ones. You said to use the button with the two prongs. Does that mean to use one of the buttons that says, “Remove seal after washing”? What does that mean, I thought you shouldn’t get electrical components wet, I have two buttons that say this. We also have a rectangular-shaped component that has three prongs, and eight, small rectangular-shaped buttons that were included in the small plastic package. Thanks for any help understanding this!

Hi Camicazi,

I posted another pic in the breadboard thread for the small push buttons, showing how Alex wired his. It may be a bit hard to see but each button is wired in the same pattern as the controller buttons. Also see LMac’s pic for how the controller is wired.

The things with the labels are buzzers, they get used at some point but I’m not sure when. If you leave the label on, it won’t be as annoying! The label is there for final wash during automated circuit board manufacturing. Boards do get washed. Some parts are sealed and some, like the buzzers, are not.

Is the rectangular component with the three leads about an inch square with a white dome? If so, it’s a passive infrared detector, or motion detector. Just like what’s in a motion activated porch light. May not be used in the Piper, I kinda remember that they would toss it in if enough people contributed.



Perhaps you’ve figured this out by now, but clicking the MIDDLE MOUSE button will allow you to access the Main Menu among other options.


  • Jordan

@Jordan, thanks for letting me know about the middle mouse, I don’t think we knew about this, because when I asked my daughter how to replay a video or how to go back to the main menu, she acted like turning the piper on/off was the only way to get back to other main menu, so this is really great to know! Thanks!

Thanks for the help here. We did not realize from instructions that the previous three prong switch must be removed before the two prong switch is installed.

We also had to use tweezers to install the tiny two prong switch correctly.