Help with new Piper


I guess I’m one of the lucky ones that had our Piper show up at the house on Christmas Eve.

Put it together with the kids; package was missing about a dozen brass screws, but I had some 6x32 of the appropriate length stainless lying about in the shop.

Situation 1: Powered the unit up - everything works up to the desktop. When I try to mouse over the task bar/dock, it “jumps” to the middle of the screen (and the menu disappears! doh!). I was able to make this behavior stop by right clicking and opening the preferences window - this seems to force the dock to anchor to the top. I was able to more permanently fix this problem by turning off the auto-hide feature, and also by telling the dock to not force itself on top of all other applications (since this combination would otherwise interfere with minecraft)

Question 1: Why is this happening?

Situation 2: Launched Minecraft Pi. Game looks like minecraft; but while there is a world around me, I dont see any of the materials described on the website, aka "you realize that you are sitting at mission control in a modified Minecraft world. You are sending a robot to an unknown planet and on the way over his hardware is damaged. Now it’s your job to build his hardware in real-life, to control him on the screen. You first build his controller to navigate. The schematic on the screen shows you how to build and gives you realtime feedback as you add your buttons and wires correctly. "

Question 2: Where is the customized world that will actually let me do what Piper is supposed to do?

Thanks for the insights!


Can't find where to load game?

Hi Joel,

Sorry to hear!

Please try the following:

  1. Plug a wired keyboard into one of the USB slots on the Pi.

  2. On the Desktop, click “Menu” --> “Accessories” --> “Terminal”

  3. In the terminal, please type “cd piper” followed by the “enter/return” key.

  4. Next, type “sudo python” followed by the “enter/return” key.

  5. In the main Piper game menu, connect to WIFI and then click “update” if it doesn’t automatically update.

  6. After the update please restart the Pi from the game menu.

I hope this helps! Please let us know.

Cheers and Merry Christmas!

  • Jordan

[Edit] added “enter/return” key


P.s. please unplug the keyboard after the game launches


I have the same problem I fear BUT I DONT HAVE A SPARE USB external keyboard. So… Please help walk me through these steps with no keyboard. I downloaded the software, burned it onto a new micro SD chip that I had to buy on my own, the raspberry pi now boots up to piper but there is no specialized Minecraft program. I can’t update because while I can click on “system/virtual keyboard” on the keyboard preferences: no virtual keyboard materializes. I restart… Same thing.
I click on my wireless connection and it asks for “Pre Shared Key” and I assume that is my router’s password. No problem as I know that: just no keyboard materializes. How do I get the virtual keyboard to pop up?
Again, no instructions requiring an external keyboard please.
Yes I can get one or wait until Monday at work but that again is another delay then before ever getting to play at all with Piper.



We’ve already shipped you a new SD card, but try the following solution for launching Piper from the desktop without a keyboard (courtesy of

1: Go to toolbar at top of desktop
2: Open up file explorer
3: Click piper folder
4: Go to game folder
5: Go to boot_files folder
6: Double click Piper2
7: Click execute in terminal (this will show any error messages that occur)


Can't find where to load game?

Hi Jordan - I got the new SD chip. Looks like it boots to the game fine! Yay! But I can’t update (if I need to and I believe I do).

When I go to configure the WiFi, it correctly identifies my WiFi. I type in the password and it will NOT let me get off the page when I click “connect”. I’m forced to click “disconnect” or " cancel" to get out of there. This occurs when I fhave highlighted the name of my WiFi. If I don’t highlight the name of my server in the wireless configure set up screen, I can type in my password and click “connect” and watch that setup screen auto close… But nothing has changed! The wireless symbol top right on the home screen still has a line through it showing it not connected and the “update” button on the bottom right of the play Piper home screen also is lightened because without an Internet connection there is no way to do that… So how about that! But still there is some progress!
I also brought home a spare USB keyboard and it works fine with the raspberry. Entry of the password was done both with the virtual keyboard and the usb one…both proved unsuccessful. Thank you!!!



Please try the following potential fix now that you have a keyboard:

Thanks and keep us posted!

  • Jordan


Didn’t work. I click ssid but makes no difference. I get out of that page and it’s like nothing saved still.


Hi, I have the same problem. Can I arrange to have a new SD card sent out please?




I have the same problem, can you please tell me how I can get a new SD card?? I have 2 very disappointed children at the moment.



Are your children able to play the game, but the unit doesn’t connect to WiFi? If so, a new SD card may not be the proper fix.



Hi, sadly no. The raspberry pi boots up and shows a demo video and nothing else. I have plugged in a keyboard and tried what was suggested in this feed but the application won’t boot up. There appears to be an error in the code.



Have you tried downloading a new SD card image and copying it to the card? The instructions can be found in the forum here.


  • Jordan


It looks like the Piper team has found the issue with booting into the desktop. See this thread