Google Chrome on PiperBot


An update, the chromium-browser WILL work IF you have enough free space on the SD card. I now have Piper and the chromium-browser working. (Thanks to @jordan for pointing at the of running out of room)



I did all the steps leading up to accessing the Pi through SSH in the mac terminal. When I type in:
ssh pi@

I get a message in terminal saying:
ssh: connect to host port 22: Connection refused

I followed the steps exactly so I don’t think I did anything wrong.

Any help would be appreciated.



I think I figured it out. I believe I have to allow SSH traffic on port 22 on my router. I’ll try that when I can as it appears I would need to disrupt the internet briefly to enable that.



Still no luck. I enabled SSH on port 22 but I still get a connection refused message in terminal when I try to run:
ssh pi@

What can I do at this point? You mentioned that Chromium worked for you with a 16GB SD card. How do you get the image onto that card? I’ll go buy one if I knew how to get everything on to it.

I don’t even care if we get chromium at this point I just want to get this back up and running but I just don’t know what to do. If I can’t remote into it to remove chromium what other options do I have.



Phooey, I know why you can’t SSH in. It was just recently that the Raspberry Pi Foundation added in the ability to use the ‘SSH file in the boot partition’ trick to turn on SSH at startup. But unless you had done the correct upgrades you would’t have it on the Piper SD.

You can download and reimage your SD card - any Progress in the game will be lost, but your son gets to play it again. Here is a link to the latest (v2.0.2image and here is a link on how to flash the SD card. NOTE: not all 8GB cards are the same size and sometimes an immage will not fit. I personally have moved up to 16GB cards to make sure I have enough room.

If you want the latest and greatest Pi software you can do an upgrade. You’ll need to expand the file system to use the full size of the SD card. In newer versions of Raspian (the OS), it is done automatically.

First open a terminal window and run

sudo raspi-config

go to ‘7 Advanced Options’ then select ‘A1 Expand Filesystem’ - and select Finish and tell it to reboot.

Now you can do the upgrade so run (NOTE: this will take a while.

sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get clean

At this point you should be running the Pixel desktop and if you are on a 16GB card, you can run the chromium-browser install.

Sorry this has taken so long, but look on the bright side - you are learning something new!


@Paul @Pi_Piper,

Just an FYI that, for security reasons, we automatically disable SSH on boot-up. If you’d like to prevent this from happening every boot, then please comment out the following line, “sudo update-rc.d ssh disable” in the PIper2 file located in /piper/game/boot_files/. To enable ssh, you can go through raspi-config as mentioned above, or you can type the following in terminal, “sudo service ssh start” [followed by enter/return].


  • Jordan


Paul, thank you for the very detailed instructions. I’m going to pickup a 16GB card in the next day or two and give this a shot.

Thanks again


For what it;s worth, I’ve been using Samsung EVO 16GB cards


Hi Paul,

Got a new 16GB microSD card, imaged it with v202 and it’s booting up fine. Thanks again!

However, when I type in:
sudo rasps-config
It says command not found.

Any ideas on that?



sudo raspi-config - blasted auto correct!!

I fixed it in the previous post


Success! Thanks Paul. All updates complete and Chromium Browser is installed.

I have one more question about Flash but I will start a new thread about that.

Thanks a million for all your help here!