Google Chrome on PiperBot



I am trying to install the Google Chrome web browser on my sons Piper computer. I have watched several youtube videos explaining how to install Google Chrome through Terminal but unfortunately I can’t get them to work. Has anyone tried this? If so, could you direct me to a good instructional video or send me the terminal commands. That would be greatly appreciated.


PS: We have installed Firefox successfully through terminal, just can’t get Chrome to work.


You can’t install Google Chrome, but you can install Chromium. As other people have posted, Chromium is the code base out of which Google Chrome is compiled. Chromium is an open-source version of this browser. Simply type the following.

in Terminal type

sudo apt-get update
sudo apt-get install chromium-browser



Thanks for response. I tried that and it did not install. It said 0 upgraded, 0 newly installed, 0 to remove and 16 not upgraded.

Any ideas as to what could be going on?



If the apt-get for chromium didn’t do anything then it is probably already installed.

in the desktop, go to the Raspberry icon and then to the ‘internet’ tab and see if it is listed


Thanks again for the reply Paul. I checked there but unfortunately it is not there.


sorry for the delay, babysitting a 3 month old.

What do you get it - in terminal - you type

which chromium-browser

if it is installed it should say ‘/usr/bin/chromium-browser’ - if nothing is returned then please type

sudo apt-get install chromium-browser

followed by the ‘which’ command again

which chromium-browser



When I type in
which chromium-browser

I do get the message back saying

So I guess it is installed. I just don’t know where to find it because it is not in the Internet menu.

I checked the file path for usr/bin/ and I do see a chromium-browser text file there.

Any idea as to where I can start the application from? Should I try uninstalling it and re-installing it? If so, do you know the commands for that?

Thank you again for all of your help!


If in a terminal window you just type


it should start the browser.

Now as to how to add it to the menu…I have do do some research (grin)


If you have updated the Pi and are running Jessie, in the desktop, go to the raspberry icon and select the Preferences->Main Menu Editor
select the ‘internet’ tab and add a new item. Fill it in with

Name: Chromium Browser
Command: chromium-browser %
Comment: Access the Internet
and you should have an item showup that will run it.


Unfortunately when we type in /usr/bin/chromium-browser we get a message saying
chromium-browser: undefined symbol: mmal_vc_init_fd
and nothing launches.

We went to Preferences > Main Menu Editor and saw that Chromium was there under the Internet tab. So we deselected and reselected and now it shows up in the Internet menu. But unfortunately whenever we try to open it we get a spinning wheel for about 10 seconds and then nothing happens.

Is it possible it is corrupt? Would there be any benefit to try and uninstall and reinstall it? If so, do you happen to have instructions for that?

Once again, your help is really appreciated!



Just an update, we tried the command
apt-get remove chromium-browser
and got a message saying that it could not remove it because the file was locked.

We tried variations of this command including
apt-get autoremove chromium-browser
apt-get remove -purge chromium-browser
apt-get purge chromium-browser

but the all produced the same results.



You need to use ‘sudo apt-get remove chromium-browser’ and the same when installing it. i.e. ‘sudo apt-get install chromium-browser’


Thanks. I think we did try that as well, but I’m not 100% sure we tried that exact command. We’ll try that soon and report back. Sorry for the delays in trying some of these but I like to make sure my son does these with me so its whenever we get time from his school work and other activities. We’ll try this soon though!



I love that you are waiting so you can do it together!!!
Make sure to use the ‘sudo’ version of the commands


We were able to successfully uninstall using:
sudo apt-get remove chromium-browser

Thanks for that command! We were also able to re-install it using:
sudo apt-get install chromium-browser

Chromium shows up correctly in the Internet menu. However, when we click on it, we just get a spinning wheel for a few seconds and then nothing happens. So, it appears to be installed, but it just won’t launch.

Any other thoughts on this?



did you try rebooting? Also type the following to upgrade the OS:

sudo apt-get update
sudo apt-get upgrade -y

I just tried on a non Piper system and the chromium-browser works. I’ll dig out a Piper card and try it.

NOTE: the apt-get upgrade WILL take a while



I just did and now the Pi refuses to log in - I need to find out what is happening


Hi Paul,

Unfortunately, I just tried it and now mine refuses to log in as well. I picked a bad time to try your suggestion right away (I tried it before I saw your most recent message telling me not to)

I had already tried sudo apt-get update before, so I know that command worked ok. So, I think it is the command sudo apt-get upgrade -y that is the issue.

So now our piper will not boot up just like yours. Hopefully you can help us get it working again. My son is a little nervous now…


Do we need to re-image this? How do I get an image?


Sorry about that. It has something to do with the chromium-browser code.

I have a way to get back in if you are capable of doing a few things - think of this as a learning oppurnitity.

You have to enable SSH to allow you to get into the Pi remotely. The tricky part is that Piper disables SSH everytimg you boot, but I figured out a get around.

First you need to find the IP address of the Pi on your network. If you have an iPhone, go to the app store and get ‘Fing - Network Scanner’. Once installed run it and do a scan - somewhere in the list you should see a ‘Edimax’ or ‘Raspberry’ - record the IP address

Next, power off the Pi and put the SD card into a card reader and connect it to your computer. Now create a TEXT file with one blank chracter and save it with the name ‘SSH’ and no extension. Now you should see a device attached to your computer called ‘boot’ - copy the file ‘SSH’ to the device and then unmount it.

Put the SD card into the Pi and power it on.

Now you have to SSH into the Pi from your computer. If you have a Mac it’s easy, if you have Windows you need to install ‘PuTTY’. Here is a link to a tutorial for installing and running PuTTY

On the Mac go to the Applications/Utilities folder and run the Terminal program. At the prompt enter

ssh pi@the-pis-ip-address

My Pi’s IP address is so I enter ‘ssh pi@’. For the password use ‘piper’ and if everything worked, you will see a prompt:

pi@raspberrypi ~ $

if so you are in business so enter

sudo apt-get remove chromium-browser

and reboot when it finishes and you shoud be all set. (and you have hacked your way around a problem :thumbsup:)

Let me know if you have problems