Game screen doesn't fit


The right portion of the game screen is outside the bounds of the physical display. I tried modifying the overscan settings in config.txt by removing the # on overscan_right=16, but all that did was shrink the overall size of the rendered screen. The game screen is still wider than the physical screen – by a lot. I can’t see the “E” and the “R” on PIPER on the game’s home screen, for example, as shown in the screen shot.

Note, too, that the bios screen and the OS home screen are rendered just fine. It’s just the game that doesn’t even come close to fitting.

How do I fix it?


Is this a fresh install of Piper? - ie are you running it for the first time after building the box?


This was after a fresh install as well as after we took all available updates. As mentioned I tried modifying the config.txt as well, and that did not fix the problem.


Hi @kiltwearer,

Can you please check that the following is in the config.txt file:


Also, after selecting a level, does the Minecraft window fit within the bounds of the screen?


  • Jordan


Hi! I have verified that the config.txt file contains that information. The minecraft window does NOT fit within the bounds of the screen after selecting a level.

What else can we try?


Hi @kiltwearer,

If you’ve disassembled the screen and checked all connections already, then you may need to re-image the SD card. Have you already updated to the latest version, v2.2.0 (which you can find by looking in the bottom left hand corner of the options menu)? If not, then please first try updating.


  • Jordan


We have version 1.0.6. When I connected to Wi-Fi and rebooted, it took a while to finally reboot. Once it did, all of the menu buttons were greyed out, and the Pi eventually transitioned to cmd screen that displayed a number of errors reading from memory.

Did it silently update or something when I connected to Wi-Fi? Can I try updating to 2.2 manually? Are there steps for that?


Hi @kiltwearer,

Updating from v106 does take a while and does pop up several terminal windows while updating. The best thing would be to re-image the card using v2.1.0 image and instructions located under topic #4 here. Alternatively, you can try to manually update to v2.2.0 by following the instructions here.


  • Jordan


We got 2.1 imaged and then updated to 2.2. Note that the Pi OS screen fits as does the boot screen. It’s just the game screen that is too large. See all three images for reference.

Fits the screen


Fits the screen


Doesn’t fit the screen


Hi @kiltwearer,

Thanks for sending the images. Can you please try clicking on “PiperCode” and then after it loads, click exit to close and return to this screen (and see if it fixes the resolution issue)?


  • Jordan


I am having exactly the same problem. Ran pipercode and it didn’t fix anything. My config.txt contains all the relevant lines mentioned above.
I have seen the resolution correct itself after running pipernet then quitting.


I have the exact same issue.

  • The lines mentioned above are in the config.txt file
  • Tried to start pipercode (fits perfectly into screen) and exit - same issue

My screens look pretty much like the ones that kiltwearer posted above.


My screen looks the same as above. Also we are unable to exit out of story mode properly and thus have been powering down which can’t be ideal.


Please try what worked for another community member here.


  • Jordan


I tried that but when pressing command+o on my keyboard it took me to the drop down menu and I was unable to save and exit the screen. Are there other ways of saving?


Please try Cntrl+x or using the mouse to close the window (Alt+F may also bring up the file options).


  • Jordan


I will try again when I get home. With the mouse I could not see an area to save the changes, only to close the window. As I said I will try again later tonight and let you k ow how I make out.


Tried the above and nothing changed. I still failed to see a save option. I also tried using another fix I found on the forum to rename the userdata file and now pipernet is locked, progress in story mode is gone, the screen remains as it was with no sound.