Connection to Server keeps timing out


My grandson tries to connect to Pipernet and we get an error message: Connection timed out

Everything works until the status bar that says “Connecting to server…”

Then we get an the message: “An error occurred: Connection timed out.”

I am with him trying to figure out what is going on. We are online and everything should be fine. We do have high latency at our house (satellite internet–we live off-grid in the Yukon bush), but speed is good. Is the latency that issue?

Grateful for wisdom from the Piper community.


I was running into that also, this might be a problem at the server end, not with your Piper.I’ll let the Piper guys know.


Thanks, Paul. Same issue this morning. Sigh. Won’t see grandson and Piper (his Christmas gift from us) until next weekend. Ah well. Will try again next weekend.


Sorry about that, the server is undergoing rapid changes and the latest ones did more harm than good over the weekend. I am the one responsible.

In case you’re curious for specifics: we tried a different way of storing all the blocks in the world — the supposedly more reliable postgresql database instead of the old sqlite3 one. It ended up causing problems than it solved.


Hi Greg.

Thank you for the update. Sounds like a bit of fun… Live and learn, eh?

FYI, if Piper is building around their own servers, you may want to take a look at




Hi Greg

We are experiencing the same issue. Any idea when this will be resolved? My son finished the all the original “missions” in 3 days and is looking forward to the new challenges.


The server seems to be stable now (as of yesterday). If not, or if something’s weird keep me updated please :smile: