Connecting wires to pin 5 and 6 at begining


Connecting pins 5 to 6 in the first level hasn’t been doing anything for me, I tried different wires and turned the piper on and off again… still nothing


Hi, Sorry you are having problems, lets see if we can ‘debug’ your issue. First can you take a picture of the wires connected to the pins and post it so I can check if you have the right pins.

Also, whenyou shut off the Piper, don’t just press the button on the battery. You should always try to use the Pi’s (that is the computer running Piper) normal shutdown procedure. If you plug in a USB keyboard, you can hit the escape key and then move the screen down till you see the top menu. Right click the itemd labeled ‘HUD’ and ‘Minecraft - Pi edition’ and select ‘Close window’. Then using the left most icon, select shutdown.

Normally when you are in teh game and complete a level you can go back to the main menu and select shutdown from it.

ALWAYS wait 30 seconds before shutting off the power so the computer can clean up after itself.

I’ll wait to hear from you.



The problem cant be the connection, because I tried several different wires
to test it, the power led indicator on the pi is solid red and its getting
hot. We are plugging the piper into the wall not the battery.


Hi Nick,

I want to make sure you’re got the correct set up as @Paul mentioned so a photo would be helpful. What’s the reason you are not using the battery? It’s not a good sign if the Pi is getting hot.



Well, my battery doesn’t work so I’ve been plugging it into the wall.



Send an email to so we can see about getting you a replacement.



Will do.

Thank you!


Here is a picture of the setup, it isn’t working still. I even hooked up to the battery now

  1. Is the Pi is booting? i.e. do you see the splash screen and video and get to the main menu?


Yes it’s booting, it just won’t let me passed this point

Nickolas Graham
JHS Student


Ok lets try something. Exit Piper and open a terminal window, then enter
when it ends, type 'exit’
next go the Menu->Programming->Python 3 (IDLE) - this will open a new window.
Click File->open and scroll to the right and select the file ‘’ - a new window will open
Click Run->Run Module and a new window will show up with a list of GPIO numbers and red led indicators.
on the right hand side, find GPIO 12 and change it from ‘passive’ to ‘input’

does the led indicator start flashing between red and green?
Touch the two wires together. What happens (the led indicator should become a steady red)

When done you can close out each screen.


I followed your instructions to a T and no led lit up or anything. I am still having the problem


Would you try one more thing? run again and change GPIO 7, 12, 16, 20 and 21 (the bottom five in the right hand column) to input. Do any of them blink?

next startup Piper (do not quit and then exit to the desktop

what is the status of the five leds?


Hi @nick4650,

In the first level, can you try connecting wires to the first two pins, touch them together and see if your player starts to move left?


  • Jordan


nothing, the leds didn’t light and the piper still didnt work


Who were you responding to? Jordan or myself?


I tried both… I’m getting a little upset with this whole deal now, what should I be doing that I am not currently? I’ve tried everything you’ve given me, and tinkered allot with it on my own. Piper is an expensive kit, and I’m yet to get the intended use out of it. Do I need new components? I’m running on piper 2.0 and everything


Hi all,

I have the same problem. At the beginning, with @Tommy, we thought of a hardware issue.
We got a new Pi, then went to vacation, busy with work…
I’ve exchanged the Pi with the new one, restarted it all, with no luck.
For us, the pins that do not work are the ones allowing to move forward and left. The right move and jump are OK.

Since I added the translation to french , I suspected it could be a software problem, linked to the translated files. I rolled back those changes, and still have the same issue.

I have the problem since the last update.
Can it be a bug due to the newest version ?



@Paul, any hints on this one ?

Thanks !


@Tintin - did you try instaling (see one of my previous posts in this thread) and what were the results?

When you run it change GPIO 7, 12, 16, 20 and 21 (the bottom five in the right hand column) to input. Do any of them blink?