Can't get to story mode

I go strait to the desktop.

December 27

what happens when you boot the Pi?

Visit Topic or
reply to this email to respond.

To unsubscribe from these emails, click here

Try opening a terminal window and type ‘sudo python

Thank you Paul,

I typed in sudo python and it says [Errno2] No such file or

What can I try next?



Sorry I have a head cold (xmas gift from my 2 year old grandson) and I should have looked it up. the command is

sudo python piper/


Hi Paul and Coder_Michael,
Did “sudo python piper/” help you get back into Story Mode? I purchased this god forsaken thing for my son and we are having the same problem. My son entered Story Mode on his first attempt but only the menu screen since then. I typed “sudo python piper/” into the terminal but received an error.

Any thoughts? We in an endless loop. Didn’t realize this was going to be so trying. I thought this was for beginners.


What is the error you are getting?
When he used it the first time, how did he shut it down?

Hi Paul,
He shut it down using the battery because there was no other way to close the program with the limited function of the piper.

The error reads:
Traceback (most recent call last):
File “piper/”, line 45, in
from import game
import error: cannot import name game

On bootup the animation starts and goes through the process. At the end of the animation we are sent directly to the menu screen. We have the option of starting Minecraft through the menu tabs but don’t get the option of story mode (only “creative mode”). Why don’t they have the story mode option in the menu? Is there anyway of getting to “story mode” from the menu screen? Or, is the only way into “story mode” from boot. UGGHHH! What is the magic spell? Anyone have this problem and solved it!

Hi Michael,
Did you get this resolved? My son is having the same issue. Did the code you received from Paul help? My son is disinterested in this thing and thinking about sending back.

Anyone have the answer? Does Piper Corp. have any help?


You are not alone, we are having the same problem too. Got into story mode once, since I have been trying to fix my kids Christmas gift…disappointing. Seems to be very common issue. Spent 2 days trying all the troubleshooting suggestions I can find. Sadly, loosing faith the more I read. Way too much money to deal with this crap out of the box.

Hi William and Paul,

We tried the “sudo python/” and although it did not give us an
error this time it also didn’t do anything or execute the program. It just
gave us another cursor line. So we are also stuck in the infinite loop of
the intro video. My son’s friend also got the Piper for Christmas and is
having a grand ol’ time - not having any problems!

Please help!

Maddie (Michael’s mom)

I had the literal exact same problem with you. It shows the loading screen and then goes to desktop. I had to do some digging around and finally found something that Tommy posted about this issue. Piper No Longer Boots AFTER Updating - Fix!. This is the link to it. If this doesn’t work, message me we will talk about further solutions.

  • B_I_T_C_O_D_E

I do believe that will fix the issue. Was about to post this.

Piper community you are all awesome! Thanks for pitching in to help. This
last fix worked like a charm.

Hope it works for the rest of you on the thread.

Check out this post…

Piper No Longer Boots AFTER Updating - Fix! - Support …
If the Piper updater is interrupted (e.g, the unit powers off) during a critical point in the update process, you may experience an issue with Piper no longer loading …

We just got our machine to work again following these steps…



That’s too bad. It’s too much frustration than I have time for. I am very disappointed with ours. I am going to return this to Amazon.

Best of luck to you.

Brad (William’s Dad)

I’ve tried entering various scripts in the terminal that was referenced here.
still not able to access story mode. I have latest updates downloaded.

What happens is story mode starts > click on mars > then click on story mode
and then it will take you to a frozen desktop (not able to click on anything)

What do I do?

Hi @daloweman,

Are you running the latest version, v2.2.0? Have you tried running the potential repair script here:


  • Jordan

Tried running the script you mentioned noted above. Still not working. How do i check to see if i am indeed running latest version v2.2.0. Im having a new sd card sent to me. Will an new sd card fix the problem?


You can check the latest version by opening the options menu (click on the “gear” icon in the main menu) and looking in the bottom left-hand corner. And yes, a new SD card will fix the issue (or you can re-image the current one wit v2.1.0 located here).


  • Jordan