Cannot Get Sound to Work


#22

@Greg yes, sound is on, volume set the whole way up before launching the Piper app. I can hear sound when Piper launches - the whole space shuttle launch video is quite loud. But once i click play in story mode and then select “Mars”, i get a lot of static and some very faint voices / dialog. this happens whether i use your speaker or a pair of ear buds.


#23

Okay!

Try editing the piper/game/config.txt file. The volume setting is in millibels and can range from -6000 (softest) to 0 (loudest).

You’d have to restart the game for it to take effect. Let me know if it works!


#24

volume on (loudest setting) and speaker recharged with green light, and still can hear the music… as a matter of fact I think it actually plays the music but in a weird white noise version… you can hear the volume of the white noise changing sort of in sync with the intro video… I changed the config.txt to volume 0 and still the same… can’t hear the intro or the video in storymode/mars


#25

Is the cable inserted all the way in? It can be kind of stiff in the beginning.


#26

fixed… volume in the piper/game/config.txt was set to -5335. I changed it to -0100 and sound is now audible and clear. note that there is still some static and and high frequency noise that is audible when the videos are not playing.


#27

Yesterday, I was setting up another Raspberry Pi 3 in my house as an Airplay server. One of the steps called for a Firmware update, and right after such update, sound was broken. I am running Ubuntu Mate 16.04 on that one.

I eventually found this and this

So, for better troubleshooting, get a USB keyboard and access the terminal on the Piper.
Then type this:

sudo alsamixer

It would probably show something like this:

Notice the line where it says:
Item: PCM [dB gain: -102.38]

And the bar in the middle with 00 displayed on it. Press the ▲ Up arrow on it to crank the volume up. Once that is done, press Esc and then run this command immediately after exiting:

sudo alsactl store

This should store the new settings and you should be hearing audio.

If this does not work, try opening the /boot/config.txt file and adding this line (anywhere on the file)

sudo nano ~/boot/config.txt

audio_pwm_mode=2

Then CTRL + X, Y, ENTER

Now reboot your piper with
reboot
or sudo reboot

When it comes back online, open Terminal again and try this final command to force audio through the 3.5mm headphone jack:

sudo amixer cset numid=3 1

One final alternative is to run raspi-config from the terminal and force audio through headphone jack from there as well.

I hope this helps!


#28

Same problem here, tryed multiple suggestions.
You might want to test the product … I hope you guys build overseas aldo it’s not cheap but get someone to update test and reset the product before you ship it.

Its a half working product , you know you might want to hire someone who can fix all the issues … instead of keep having excuses for problems that first are noticed in end 2015…

I ran the updates but still same sound stuff…
Imagine I wanted to sponsor this product to schools…

Best regards

Ps I still hope you have a solution because 300 buys me a lot better stuf then this…


#29

Same here, was working well, and all of the sudden, only in story mode (first launching video play loud sound before entering story mode), no sound, or better, a white noise with almost inaudible sound trace of the story sound. Idem for the PiMusic planet, impossible to play because the sound is so far away with very present white noise. Which stops right when we quit the game. On other apps sound works well. I tried every fix, including the alsa mixer in terminal and all others: no luck. So to me this looks like a piper software bug, you guys might want to look into. I’m running Piper workshops and this is concerning. Please put it up on the top of your troubleshooting list: it seems a certain number of people experienced this without succeeding in finding solution. Thanks for your help !


#30

We do appreciate you letting us know, what version of the software are you running?


#31

The last one, it seems. 2.2.0. Also sometimes my son gets a flashing screen that makes it almost impossible to access the quit menu (scroll button), but after a while moving around with the mouse and the buttons it stabilizes and lets us access the quit feature.


#32

Thanks for being on top of the case, by the way ! Fast as always :wink:


#33

We’re full speed ahead working on an update with fixes!


#34

Hi Jordon. Can you please also let me know how to get a replacement speaker. I have fully charged the Piper Speaker (the green light is on) and have turned it on but cannot get any sound. I have plugged earphones in and the sound is coming through them fine. So it is definitely a defective Piper Speaker. Otherwise, everything else in the kit is great and my son and his friends are loving playing with it.


#35

@JamandSoul - just a quick question, if you plug the speaker into a phone, do you hear anything?


#36

HI Paul. I have plugged it into a phone and a laptop and tried to play music through it and could not hear anything. Cheers

John


#37

I sent a note to the piper guys.


#38

Hi John - send an email to hi@playpiper.com and we will get you a replacement speaker ASAP.

Thank you!

Tommy