Cannot Get Sound to Work


Sound worked originally when we started the kit. Now, nothing. It’s hooked up correctly and the settings say the sound is at full blast. Help.

Also, would like to know how to save where my kid is in the building process. He shut down yesterday and now he has to start all over.

Thank you.


Same here. Sound is gone. Updated the system. Made sure speaker was charged. We still get notification tone, but nothing else.



If you are playing Story Mode, then there is sound for 1) the videos and 2) chat notification ping as @doylet mentioned. There are gameplay sounds in PiperNet as well. Are you hearing the chat notification pings? If you re-play the Mars level, do you hear any sound in the first/intro video?

Also, you cannot save progress in the middle of a story mode level, however if you already have the hardware set up then you can get back to where you left off relatively quickly.


  • Jordan


We have the same prolem. Our son is 6 and cannot read the messages so quickly, so we absolutely have to get the sound working.
Tried to connect speaker to my phone but could n’t hear anything either.
Already the SD card did nt work, now the speaker. We are disappointed for the price we paid for the kit and the shipment…
Not to speak of my frustrated 6 year old son…

How can this be fixed??


Make sure to charge the speaker. I had the same problem when we first built our Piper - the sound didn’t work. It wasn’t clear to me that the speaker has its own battery and has to be charged separately from the main battery that powers the Raspberry Pi and screen. Use the same short green wire with the micro USB end - plug the micro end into the speaker, and the other end into a computer or USB wall charger.
You can try some headphones/earbuds while the speaker is charging.


Not only does it need to be charged, but there is an on/off switch - make sure that is on the on position. If you look under the switch you will faintly see ON and OFF. ON should be to the left.

Looking down at the speaker, the switch has to be slid clockwise for ON


Thanks all. I have charged the speaker (thank you @joshf oshf - didn’t realize I needed to do that). @jordan, i wasn’t hearing anything at all - either on videos or in notification pings. I plugged in another mini speaker (not from this set) and the sound works. Appears to be a defective speaker. What is the best process to get it replaced?



Good detective work there! I’ll send you a separate message with how to get a replacement.


  • Jordan


running build 22.0. we have sound on boot,but no sound in story mode. i followed this, but it did not fix the problem


I have the same no sound problem. That worked for one / two days. I thought that was a speaker charge issue. But then speaker fully charged, still no sound. Then I tried with another JBL external speaker, and still no sound.
I am wondering then if that is an HW issue or OS level setting pb. I tried OS level setting without success.

Is there any way to test the basic HW sound ? Like a beep command or something ?


One thing to check is right clicking the speaker icon in the taskbar on the desktop (you’ll see it top right after hitting exit to desktop). You should see a dropdown with two options: analog and HDMI. Analog is the setting you want, so click it and see if that helps.


I could finally establish that this is not the HW. I can play the pythons game coming from Raspberry pi like Tetris and they have sound. So that is “only” Piper game issue, which absolutely need to be figured out for the kids to play. I am using a basic headset plugged directly in Jack. And the output is forced to Analog.
Can piper team give some hints ?


Same problem as you. Confirmed it is not the speaker, despite the fact that the weak jack on it already broke… I am using an alternat espeaker and headphones which are confirmed working on other jacks.
searching some Raspberry Pi specific forums for info, I found this test to verify:

Sound does not work at all, or in some applications

Sound is disabled by default because the ALSA sound driver is still “alpha” (not fully tested) on the R-Pi. To try out sound, from the command prompt before “startx”, type

sudo apt-get install alsa-utils
sudo modprobe snd_bcm2835
sudo aplay /usr/share/sounds/alsa/Front_Center.wav

If you can hear a lady’s voice saying “Front Center”, then sound works on your Raspberry Pi and the configuration of Piper is the problem!

Accessing the Piper Computer Card using a Mac (backing up level progress)

Hi there,

I have the exact same issue as described, to me it happened yesterday, I was wondering if it is related to starting the use of a plug and play wireless keyboard, since for me the issues seem to happen right after that, was is the same for any of you? did it happen after starting to use a keyboard?



Just sharing an additional understanding:

Minecraft has no sound on Raspberry pi and that is normal. Because this game was ported to the platform by goodwilling people and support stopped, and they did not port all.

So that it isn’t normal then that the game is silent : steps, tnt, falling, whatever will make no sound. And piper game is made on this Minecraft for Pi.

What I am not clear about is about the piper videos sound… I have to replay Mars and see if now I get sound or not…

Also there are some guys having added sound to Minecraft Pi, and I plan to try that, since that should benefit piper game.

And the addition of a USB keyboard should not mess up the sound. I have that and get sounds on other games like Tetris on the raspberry.

Let’s stay tuned. Piper team should help a little bit as well to confirm where we should expect sound or not in the piper game itself


still no sound in piper mode. inital loader screen has sound, selecting mars and going thru the first level does not. plus the text scrolls by so fast i can’t read all of it, nevermind my 8 yr old.


Is sound turned all the way up in your Piper options? Is the speaker plugged in and turned on with a glowing green light?


I realised about something that might give a clue to the developers Greg or Jordan on how to fix the problem. If you disconnect the HDMI cable from the raspberry before booting you will hear the sound from piper intro no problem. But then you connect the HDMI cable and the screen will not show anything. There is some conflict between the two outputs, somehow it either gets the piper game video or the sound right but not both.


Have you tried this solution? Cannot Get Sound to Work
It’s the setting that switches the sound from HDMI over to analog.


yes I tried am cant hear with any of the two settings