Brand new piper won't boot - error message VFS : Unable to mount root Fs


#1

My son received a brand new piper today for his birthday . We assembled it easily with the blueprint and powered it on. It worked for all of 5 minutes then screen went dark and wouldn’t power back on. On attempting to reboot we got the following error message " end kernel panic- not syncing; VFS: Unable to mount root Fs on unknown - block (179.2).
I have been through this entire forum, emailed customer support, searched the Internet and not come across a solution. It appears to be a common problem though as there a many threads on other raspberry Pi forums and blogs that make reference to it - but no solution as yet. This is incredibly frustrating and disappointing given we’ve had this Piper for all of 2 hours during which time it has worked for approx 5 minutes. Please help.


#2

Do you have access to an SD card reader? if so could you pull the SD card out of the Pi and put in in the SD card reader adn plug it into your home computer (I hope you have one.)

Look - on the disk that mounts - for a file called cmdline.txt and copy the contents and paste it to a reply.


#3

Hello Paul. Thanks for the response. Unfortunately we’re on vacation with no access to a pc or SD card reader currently - just a pair of iPads . This is a brand new piper straight out of the box though. Is there no quick fix? It seems ridiculous that one should have to go through so much trouble without even having used the device at all.
Frustrated and disappointed.

Femi


#4

@Femi - Sorry i couldn’t get back to you sooner, I was babysitting grandkids.

Because it seems to have something to do with the SD card, without access to another computer - at the moment - there is not much you can do. And since you are on vacation, even if the Piper guys sent you a new SD card, you probably wouldn’t get it till you got home.

I feel your frustration but look at the bright side (as dim as it may look right now) The idea is to get your child hacking and seeing the workings of a computer. Learning to reload the OS on the SD card is part of the process of running a computer and getting hands on experience.


#5

Same issue with our purchase. Why don’t you just send the right SD cards to start.

Not a warm advertisement for your product. Stupid.


#6

See my response on the other thread