Brand new piper powers on but won't boot


I bought this new from Piper in June 2016 so I’m guessing it is the latest version.

Assembly went fine, the memory card is inserted. Upon power up the LCD comes on for a few seconds then goes black since it received no signal. The red LED on the Pi is on but otherwise there is no sign of life.

What next?

Editorial: We are very impressed with the quality and design so far. My 9 year old son had a great time putting it together with minimal help from me. He was all excited to turn it on only to find that it doesn’t work. I’ve worked with Pi’s in other projects and I’m reasonably sure everything is setup correctly so I’m pretty disappointed that this didn’t just work.


Hi @TheFlyingDave,

Sorry to hear! When you power it on, do you see a green light blinking at all next to the red light? Also, is the red light solid or blinking?


  • Jordan


I have this problem, too. There are no blinking lights, just a single solid red light as soon as I plug in.

Your answer here seems to indicate it might be a bad Raspberry Pi. Piper v1.2 / Pi3 won't power on

So do I need another one?

BTW: I see that the SD card is readable by my computer and has a number of files on it. I used another SD card of my own with the latest PiperV1031.img image but that doesn’t work, either.

Raspberry Pi 3 does not boot

Red light is solid. No green lights whatsoever.


@TheFlyingDave @trentlarson


Sorry to hear! This sounds like a hardware issue with the Pi. We’ve noticed on the Pi3’s that there is a hardware component that is highly susceptible to physical damage. Could you please email me a picture of the bottom of your Pi (at We are working on redesigns of our packaging and pi-case to help prevent this from occurring in the future.


  • Jordan


Hello customer support: Can I return for exchange or is this on me?

Also FYI to the community:

We just got our piper and My 11 year old son has been enjoying putting the physical parts together, We haven’t powered it on yet, but I think we’ve found the component that is highly susceptible to damage the hard way. One of the surface mount chips fell off! :frowning: The cause is that the chip is slightly higher than the rest in that area and when mounting it to the plastic stand that comes with the piper the plastic is not routed out where the chip is. Tightening down the board ever so slightly places much of the stress onto this chip and it breaks off.

Kind of frustrating since this is not kid proof. I understand this is a new version of the Raspberry Pi (3). Either way when I get a new board I’m going to epoxy the chip ahead of time and carefully check and contact points and dremel them out before handing back to my son.


Hi @jngchezem,

Our apologies about the piece falling off. We’ve looked into potential Pi case redesigns because of this issue. Please send me an email at and we can get a replacement RPIII sent to you ASAP.



Hi @jngchezem,

Thank you for the detailed post. Yes, this component is new to the Raspberry Pi3 and (I believe) is related to WiFi connectivity. While you wait for a replacement and assuming the pi boots normally, your son should be able to play the first several levels of the game and explore the desktop environment without issue. You just won’t be able to update the software and download more levels unless you directly connect the Pi via ethernet cable to your wireless router. Just move the SD card into the replacement Pi and your son can carry on where he left off.


  • Jordan


We received a replacement Raspberry Pi and it works great! Thank you.


Dear Jordan and Tommy

Hi, I am facing the same issue.
I bought Piper in July. (I was in US for biz trip, I brought it back today to Dubai where I stay)
Piper is not booting (solid red light)

  1. SD Card seems to have files on (Cant try to update the SD Card as download link is dead)
  2. Screen when powered shows blue screen for 2~3 second and goes black
  3. When RB Pi is powered, only Red light comes on

Please support us ASAP as kids are getting restless


Hi Moon,

Sorry to hear! A community member, Paul, has posted a link to our latest v1.0.5 image. You can find it here: Wiring instructions

Please let me know if his download link works for you. If so, please try re-imaging the SD card using the instructions here:


  • Jordan


Hi Jordan

There are no link to latest v1.0.5 image.

Paul’s link takes me to here

If you have a direct link kindly share.
Any chance re-imaging the SD Card will solve my issue? (Red Solid Light?)

Thank you.


Hi @Moon,

Do either of the image links (v103 or v102) work for you here: HOW TO: download/install the Piper SD card image

If so, please install, connect to WiFi and update. This may solve your issue as the symptoms are similar to having a corrupt SD card, however it could also be a faulty Raspberry Pi. If you’re able to re-image your SD card then we’ll know for sure (unless you happen to have another Raspberry Pi around to test the SD card).


  • Jordan


Same issue here. Solid red light on the board.

Tried another SD card flashed with 1.03 with same results.

Will email you a pic of the board back.


Same issue here too. We have been getting a solid red light and I’ve tried flashing the SD card with 1.03. The first time, it worked after flashing but it has not worked since and I’ve tried refreshing 2 more times. I will email a picture of the board also. Thanks!


I am having the exact same problem. Blue screen for a few seconds then nothing. Lights are on the pi. Tried different power source. Seems it is likely the pi. What do I need to do to fix this?


Tom if you have another micro usb cable around try swapping it for the one going from the battery to the pi.

When did you get your kit?


I already tried another power source. My son got it as a parent for Xmas from his uncle.



Hi Tom, sorry I wasn’t clear, I’m not talking about the power source (i.e. battery) I’m talking about the cable that connects the battery to the Pi. There was a bad batch that was only discovered after kits were shipped. (If you have a bad one, Piper will replace it at no cost)

If that doesn’t work, tehn try following this guide;