Unable to ssh to piper


#1

Hi - I’d like to ssh to my piper as part of a project my son and I are working on.

  1. I’m on a windows machine (sorry) - and downloaded PuTTY
  2. I’ve confirmed the piper address to be xxx.xxx.xxx.20 (i used the keyboard emulator and ifconfig on the piper to do this)
  3. when i try to connect using putty, I get network error: connection refused

About the only thing I can think of is that there’s no ssh server installed (or running) on the piper but I don’t know how to check. Several posts I’ve read imply (but don’t state) ssh is all set up and should “just work”.

Help?


#2

Piper shuts off SSH by default. If you want to SSH into it ou will need to edit a file and comment out a line of code.

Start up the Pi and exit out of Piper.
Open a terminal window
enter:
nano piper/game/boot_files/Piper2
and comment out the line,
sudo update-rc.d ssh disable
by adding a ‘#’ to the beginning so you have:

sudo update-rc.d ssh disable

Then press ctrl-x and the letter ‘y’ then press return.

Now go to Menu -> Preferences -> Raspberry Pi Configuration, click the ‘Interfaces’ tab and enable SSH, press OK and you should be good to go.


#3

Paul,

Thanks for the quick reply and detailed steps - super easy to follow.

Appreciate it!