Unable to see our wifi network


#1

Hi…we are unable to see our wifi connection either through the Minecraft interface or using the command I saw in the forum sued …iwlist…Etc …that picks up only 3 local wifi networks …when I do an ifconfig wlan0 I am not seeing an 192. Internet address …I see inet6 add : fe80: :ba27 etc…can you please help us sort this out


#2

Can someone please help. It is extremely frustrating to have to spend so much time trying to simply connect to wifi… my son is not profiting from this kit because of this issue and I honestly don’t want to be passing my days entering command lines in a terminal window … I have already tried several of the suggestions in the forum and from Youtube videos…


#3

Do you know what type of WiFi security you have on your router? WEP, WPA-PSK, or WPA2-PSK?


#4

Hi

The WiFi security is currently WPA-PSK


#5

If you exit out of Piper to the desktop and click the WiFi icon on the top bar, can you select the network and enter the password there?

My method is to actually edit the configuration file for the WiFi and if you are willing, here is what to do:

  1. open a terminal window
  2. type: wpa_passphrase your-ssid your-password
    make sure to enter your ssid and your passwords - this generates a WPA PSK from an ASCII #passphrase for a SSID.
  3. type: sudo nano etc/wpa_supplicant/wpa_supplicant.conf
  4. change it so it reads:
    country=US
    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    update_config=1
    network={
    ssid="your ssid"
    psk=outputfromabove
    }
  5. press ctrl-x
  6. press ‘Y’
  7. press enter
  8. type: sudo reboot
    and see if that now connects.

One of the things I do is cpy the info in the wpa_supplicant.conf to a text file on my Mac and save it as wpa_supplicant.conf - then if I have to rebuild the SD card, I just copy it to the ‘boot’ drive of the SD card and it will automatically be copied into the ‘real’ wpa_supplicant.conf file and I don’t have to type it all in.


#6

Hi
So I did as you suggested.In the raspberry Pi interface where you see the two computers it now says wlan0: Configured 169.254.184.169/16 but still no internet access (I tried opening the browser to see if I could access any website) and in the Piper interface I am still only seeing 3 other wifi networks from my neighbourhood but not mine. I was also seeing these three in the raspberry Pi interface before making the changes you suggested.
So not sure if where we go from here.
Thanks for your help
RegardsSheila

Paul
January 1 |

If you exit out of Piper to the desktop and click the WiFi icon on the top bar, can you select the network and enter the password there?

My method is to actually edit the configuration file for the WiFi and if you are willing, here is what to do:

  • open a terminal window
  • type: wpa_passphrase your-ssid your-password
    make sure to enter your ssid and your passwords - this generates a WPA PSK from an ASCII #passphrase for a SSID.
  • type: sudo nano etc/wpa_supplicant/wpa_supplicant.conf
  • change it so it reads:
    country=US
    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    update_config=1
    network={
    ssid="your ssid"
    psk=outputfromabove
    }
  • press ctrl-x
  • press ‘Y’
  • press enter
  • type: sudo reboot
    and see if that now connects.

One of the things I do is cpy the info in the wpa_supplicant.conf to a text file on my Mac and save it as wpa_supplicant.conf - then if I have to rebuild the SD card, I just copy it to the ‘boot’ drive of the SD card and it will automatically be copied into the ‘real’ wpa_supplicant.conf file and I don’t have to type it all in.

Visit Topic or reply to this email to respond.

In Reply To

Liam
January 1 |

Hi The WiFi security is currently WPA-PSK
Visit Topic or reply to this email to respond.

To unsubscribe from these emails, click here.


#7

@Liam - do you see the SSID on other devices? i.e. is it a hidden SSID or publicly broadcasting?


#8

Hi …I see the SSID of only 3 other devices in my neighbourhood whereas from my phone for example I see around 6 wifi networks… our SSID is not hidden. We have a wifi extension connected to our router. Would that make any difference ? I don’t see either the router or the extension from the raspberry pi.


#9

Sorry I didn’t think of this earlier.

Go to the desktop. Click the Raspberry icon and go to ‘Preferences’. Then select ‘Raspberry Pi Configuration’.

Select the ‘Localisation’ tab and set the WiFi option to your country. Reboot and see if that works.


#10

Just did that and no change at all.
Is there anything else in there you might think needs to be set for France where I am located?
Also on my wifi router it says I am using version 2 of protocol EAPOL whatever that is. I have the option to change this to version 1.