Raspberry Pi lights do not come on!


#1

We built out computer kits today and when we turn on the battery pack the screen went blue and then black. The raspberry pi never did start blinking like the other ones we have. What can I do?
Thank you,
Spring Charles


#2

Is the battery fully charged?


#3

Yes, I charged all of the battery over night, so that my students could start working Piper after they completed putting it together.


#4

Hi @scharles,

Did this occur on only one of your kits or on all of them? This will occur if there is no SD card inserted or if the card isn’t seated properly (or if it’s corrupted). Also, do you see a solid red light?

Thanks,

  • Jordan

#5

It is only happening on one of them. No lights will come on at all on the raspberry pi. The card came already inserted in it. It has in all of them that we bought. I have unplugged everything and replugged. The screen will come on and turn blue and then go black.


#6

Hi @scharles,

Thanks for the update! To help rule out an issue with the Rasp-Pi itself, could you please try swapping out the SD card it currently has with one from a known working unit and try again? If this works, then we can assume that the SD card is corrupted and work on a fix (i.e., re-imaging it) or issuing you a replacement ASAP.

Thanks!

  • Jordan

[edit] p.s. If this doesn’t work then we can assume it’s the Pi (as @Paul points out below) and issue you a replacement. But please confirm this by swapping in a known working Pi just to make sure it’s not related to a different piece of hardware altogether (e,g, faulty power cable).


#7

Since you have more than one Pi, try swapping SD cards from one of the other Pi’s. Then swap the Pi’s from one Piper to another. This will determine it it

  1. is a bad SD card
  2. a bad Pi
  3. something else

#8

Good morning! I switched the cards and nothing happened still. So now I am thinking it is the Pi. All of my other ones are working great!!!


#9

Did you move another pi to this box just to check it is not a cable problem?


#10

I am having the same issue, I only have one kit and no lights at all on the Pi.


#11

@Carrie - (1) is the battery fully charged - i.e. if you push the battery button, do all four lights light up?
(2) does the screen light up at all?
(3) have you made sure the SD card is firmly pushed into the Pi?


#12

Hi,
Battery is fully charged and screen turns blue then black. SD card is pushed in. No lights on the Pi, even when I use a different HDMI cable and plugged into my tv.
I ordered a new Pi 2 days ago but haven’t received the tracking number yet?
Carrie

Paul
December 27 |

@Carrie - (1) is the battery fully charged - i.e. if you push the battery button, do all four lights light up?
(2) does the screen light up at all?
(3) have you made sure the SD card is firmly pushed into the Pi?

Visit Topic or reply to this email to respond.

In Reply To

Carrie
December 27 |

I am having the same issue, I only have one kit and no lights at all on the Pi.
Visit Topic or reply to this email to respond.

To unsubscribe from these emails, click here.


#13

Hi Carrie,

It sounds like you’ve ordered a replacement Pi already. You should receive the tracking information shortly, but if not please send an email to hi@withpiper.com with your order details.

Thanks,

  • Jordan