Package/Non-image based installation


#1

Hi!

My kids have enjoyed their Cheesteroid adventure, and are now ready to use our Pi for more things.

I’m familiar with RetroPie, and have installed it before. However, when doing a package-based install of RetroPie from an existing Piper imaged SD card - instructions here:(https://github.com/RetroPie/RetroPie-Setup/wiki/Manual-Installation#install-retropie ) - certain package installations fail, and I run into conflicts where both applications (Piper and RetroPie) attempt to autostart.

I was wondering, can I do the reverse? Can I load a RetroPie image, then manually install the packages for Piper? So far I have only seen instructions on creating a bootable SD card from an image. I understand it’ll boot to RetroPie, but I wouldn’t have a problem dropping to a terminal prompt and manually launching Piper when needed.

Thanks!


#2

Why not just have two SD cards, One with Piper and one without. I haven’t used RetroPie but jut use jessie and haven’t had a problem


#3

Hi Paul,

That’s a good suggestion. I should have included the reason in my initial post. The way the Piper kit mounts the Pi, the SD card is mostly obscured. The Pi 3 units don’t have a spring-loaded SD slot, so you end up partially disassembling the kit and/or using a pair of tweezers to switch cards. If that’s the only solution, I can go that route - I was just wondering if there was a way that didn’t require a second card and some disassembly.


#4

Ah yes, I miss the spring loader.

From my quick reading of retropie, I think it would be best to keep it and Piper on separate SD cards. I know that the autostart of Piper is part of the Pi startup programs and if Retropie is doing the same thing, I can forsee problems.

Ever think about just getting another Pi? :grin:


#5

I have, and am not completely opposed to that route. :wink:

Just trying to weigh all my available options. It doesn’t look like the Piper specifically NEEDS to autoload, it just does for easier use. RetroPie is a little different in that it doesn’t play nice with X, so you have to shut down X prior to launch. Any additional input @jordan , @greg or @danny_piper ?


#6

Heya,

I see two places where it might be autostarting from so you might have to try both, but I’m confident one will work out. I’d strongly recommend making a copy of the original files first.

To disable autostart:

  1. /etc/xdg/lxsession/LXDE-pi/autostart - try removing the third line in this file says @sh /home/…/Piper2
  2. Remove the entirety of /etc/xdg/autostart/piperBoot.desktop

P.S. There’s a good chance you’ll need root, so remember to open your text editor / prefix your rm command with sudo.

Cheers,
Greg