Menu Missing and Update Error


#1

My friend was trying to connect my Wifi to the Piper and accidentally removed the Menu from the desktop. We can still see Piper but nothing else, no panels or programs. How do we get the menu back?

I ran the Update too and now are getting the Information window error. “Oops! An error occurred during the last update…”. I tried the the fix here, but it did not work. Piper No Longer Boots AFTER Updating - Fix!

I can no longer launch the Piper program. Please advise.
Thank you.
Tonya


#2

Let’s tke one thing at time. The missing menu.

  1. is the task bar at the top of the screen?
  • if ‘YES’ right click on it and select “Add / Remove Panel Items” and then add the menu item back in.
  • if ‘NO’ move the cursor to the top of the screen - does the panel show up
    • If ‘YES’ right click and go to ‘Panel Settings’ then ‘Advanced’ and uncheck the ‘Minimise panel when not in use’ box
    • if ‘NO’ just right click anywhere on the desktop and in the Appearances Settings’ window, select the Menu Bar’ and hit the ‘Defaults’ button

#3

Hi Paul,
Thank you for reaching out. The only thing I can see on the desktop is the Piper icon. My menu, task bar, etc are all gone even when I move the cursor to the top of the screen. I can get to a Terminal Window by right clicking but that appears to be all.

My responses to your steps are in blue text.

  1.  is the task bar at the top of the screen? No
    

a. if ‘YES’ right click on it and select “Add / Remove Panel Items” and then add the menu item back in.

                                                           i.      I do not have this option (refer to attached screenshots)

b. if ‘NO’ move the cursor to the top of the screen - does the panel show up - No

c. If ‘YES’ right click and go to ‘Panel Settings’ then ‘Advanced’ and uncheck the ‘Minimise panel when not in use’ box

                                                           i.      I do not have this option (refer to attached screenshots)

d. if ‘NO’ just right click anywhere on the desktop and in the Appearances Settings’ window, select the Menu Bar’ and hit the ‘Defaults’ button

                                                           i.      I do not have this option (refer to attached screenshots)

It is like my panel settings are completely gone. Help!

Thanks.

Tonya


#4

I the last image, what happens if you click ‘Desktop’?


#5

It gives me an option to add a new desktop (desktop 2), desktop 2 it looks the same (as desktop 1)and does not have the menu or any other items.

Tonya


#6

are you clicking the wheel on the mouse or the right mouse button?

When I press and click the wheel, I get the window you show, but clicking the RIGHT mouse button, I get the Desktop Preferences window.


#7

I get similar results no matter if I click the wheel or right click. I can add new desktops, remove them or toggle between them but none of them have the menu. Screenshots are attached.
[image1.jpeg][image2.jpeg]


#8

can you try another mouse?


#9

Yes I tried another mouse and have the same results. I do not have any of the options you appear to have. Can I send the unit back you to troubleshoot or return this and get a new unit? We only used this one day and after the attempted update can no longer launch Piper.

My nephew really wants to use this for his science project next month but we have been trying to get this back and running for over a week now with no progress.

Please advise. Thank you.
Tonya


#10

Try this:

Open a terminal (Terminal Emulator) and type in lxpanel (followed by enter). You will need to keep the terminal open to keep the taskbar running. If you want to be able to close the terminal, run

lxpanel &

instead.


#11

Thanks Greg. While this did not work for me, I actually I followed some instructionshttp://community.playpiper.com/t/update-error-message/1401/28?u=tkauhi I found on the forum last night to upgrade, once I restarted this am, my menu was back, thank goodness! However, I still cannot start the game. Just the initial video loads and then it goes right back to Desktop. When I click on the Piper to open, same thing happens.


#12

Please do the following to help us troubleshoot:

  1. Open a terminal window via the panel at the top.
  2. Type in the following:

cd piper && sudo python start.py

  1. Hit enter.

  2. Post a picture of the error that comes up in the terminal.
    Thank you!


#13

Sure, please refer to the attached photo.


#14

Thanks so much for your post. Weird that this never came up on our end, but the following steps should fix it:

  1. Open a terminal window via the panel at the top.
  2. Type in the following:

leafpad piper/game/game.py

  1. Scroll down to the 32nd line which should say

from levels.lottaLava import LottaLavaLevel

  1. Completely delete that line.
  2. File -> Save

That should do it.


#15

No still cannot access the game, still launches the intro video and goes right back to the desktop. I entered the command sudo python piper/start.py and the results are attached.

Thanks.
Tonya


#16

So I’m having the issue where it says it’s now finishing the update and it could take up to 10 minutes but when I give it the command to see the progress of the update I get “command not found”


#17

Don’t use quotes around the commands. That causes the computer to think it is all one big command and that is what the error is telling you.


#18

I’ll give it a shot, but regardless of whether or not I can see the progress of the update, it seems to never finish. I can leave it unattended for over an hour and nothing happens, then if I restart I get the same message about the update not being complete and it could take up to 10 mins.


#19

Hi Justin,

Did the command without the quotes work? Otherwise you can try the fix the devs proposed to this issue here.

Thank you!

Tommy


#21

The command without the quotes worked I guess, It didn’t really show me progress of any downloads. I then tried the link that you provided and everything seemed to work as planned up until I tried to open the Piper game and then I got the same msg about an error occurring during the last update. Now finishing update. This process could take 10mins to complete. =(